testors airbrush help

Discussion in 'Getting Started' started by emt49, Apr 18, 2005.

  1. emt49

    emt49 Member

    can anyone help me out i got the testors airbrush and compresor kit at walmart. i get it home and the compresor seems to work the brush blows air but no paint.anyone got any ideas or tips for me i tryed every thing from thinned paint to just thinner and its not blowig any paint just air. i tryed a friends air brush that he told me worked and that one dose the same thing air but no paint. :curse:
  2. ezdays

    ezdays Out AZ way

    Well, I hate to suggest this, but did you read the instructions that came with it?:rolleyes::rolleyes: There might be some hints there, but the first thing that comes to mind is possibly the tube that sucks the paint up may be clogged. You might start by using water or thinner to start with to see if the sprayer works, then try paint.

    Just a thought....:wave:
  3. McFortner

    McFortner Member

    That or the compressor is running too high. I can't remember off hand what the pressure should be....

  4. Matthyro

    Matthyro Will always be re-membered

    From my experience with other makes of airbrushes the pressure should be somewhere between 20 to 40 psi. You may want to check the tube that goes into the paint bottle to be sure it isn't blocked.
  5. emt49

    emt49 Member

    i checked for clogs last night and the new airbrush was ok and the one my friend let me use was cloged but i cleand it and thay still dont blow paint. i even tryed just thinner and thats not worken

    the compressor is a testors compressor that comes in the kit it dose not have any gauges or air ajustmints . the instructions are no help they are all pics no words lol .
  6. Modellbahner

    Modellbahner New Member

    I got a similar problem with my first airbrush for 12$:eek: from the fleamarket. The problem was, that the tube in the paint can was clogged by the can bottom. After cutting a short part of the tube it was running better. Check the distance between the tube and the bottom of the can.


  7. ausien

    ausien Active Member

    the only thing that I can think of is are you puting you finger over the small hole in the air brush, to direct the air to the paint and pick it up. sorry if this is to simple, but have been there before....have a good one ..steve
  8. emt49

    emt49 Member

    on the new airbrush i have never looked at that i will give it look see but my friends airbrush is gravety fed and that one also dosent work .
  9. ausien

    ausien Active Member

    OK lets run through a check list:

    1, Have you read the instructions?.

    2, Have you conected the air brush correctly to the air supply?

    3, have you filled it with thinners, to clear any blockages?

    4, Trimmed the pick up hose from the botton of the jar/pot?

    5, Have you been shown how to use it, or had it checked out?

    this check list may seem stupid, but I find that it is the most stupid little things that trip us/me up, and I kick myself for knowing better and not doing it in the fist place...have a good one..steve

Share This Page