Proto 2000 DCC F7B won't run: Help!

Discussion in 'HO Scale Model Trains' started by SDShelley, Aug 18, 2010.

  1. SDShelley

    SDShelley New Member

    A few weeks ago I purchased a Proto 2000 F7 A & B combo with DCC from a not-so-local hobby shop. I finally tried to run it the other day and while the A unit works fine, the B unit doesn't. F6 will start up the sound, after which the throttle will rev up/rev down the engine sound, but the unit won't move. It's as if it is in "disconnect" stage. F9, which should control the 3 stages (disconnect, standby and shut down) honks the horn; does nothing else. I have to take the unit off the track to turn it off. F2 also honks the horn, as it should. F1 rings the bell; the other "Fs" appear to do their thing. I tried a hard reset (several times) and, while the voice said "reset," it didn't correct the problem. Also tried the unit on straight DC and while it produces engine sound, it won't move. (My ancient DC power pack has "issues" and I couldn't fully check the other functions the unit is supposed to be able to do on straight DC.)
    Anyone have suggestions as to what is wrong? Bad decoder? Incorrect wiring? I'm a real novice at this sort of thing and wouldn't recognize the latter.
  2. Trainiac77

    Trainiac77 Member

    Sounds like the wires going to the motor are disconnected. Perhaps you should start there?
  3. Bill Nelson

    Bill Nelson Well-Known Member

    DCC is cool especially with sound, It can make diagnostics very complicated though,

    You know the decoder is getting power cause the sounds work from DC and DCC.

    as suggested, toy may have a wiring issue between the motor and the decoder , you could have a bound up mechanism, or a bad motor.

    I don't know how this locomotive is set up, I'm a backwoods steam guy; If you can get inside, a lot of locomotives these days have flywheels, and you can roll the flywheel with your fingers, and that should move the wheels. if the flywheel won't move something is bound up. from there it is a matter of moving each truck to see where the bind is. if the mechanism rolls freely, then there is a motor or wiring issue.

    I'm not real up to speed on DCC, But I imagine a voltmeter at the motor leads would be safe. no voltage would mean there is a wiring or decoder issue, and voltage would be a motor issue.

    Contact the manufacturer first, it there is a common problem, they may be able to point you at it, or tell you what you need to do to get it resolved.

    Bill Nelson

Share This Page