dockside switcher

Discussion in 'Getting Started' started by jimbogibbo, Jul 10, 2007.

  1. jimbogibbo

    jimbogibbo Member

    does anyone have a remedy for the switcher slowing down to a crawl when the smoke unit is turned on! they run great with the smoke unit turned off , but when i turn it on they both come to a crawl!!! this is two different locos. that do the same thing.:confused:
  2. Nomad

    Nomad Active Member

    Bigger power supply. More amps to the track. Sounds like the smoke units are drawing a lot of current.

  3. jimbogibbo

    jimbogibbo Member

    is there a powerfull power pack for these units.???
  4. Nomad

    Nomad Active Member

    What are you using now, one that came with a train set?

  5. nachoman

    nachoman Guest

    I assume this is 3-rail O scale?

    My guess is either and undersized or failing power supply, or a smoke unit drawing too much current.

  6. Renovo PPR

    Renovo PPR Just a Farmer

    What transformer are you using? If I'm correct this is an O gauge locomotive.

    With out much more information I would have to guess. My guess is that you are way under powered with the current transformer you are using.
  7. jimbogibbo

    jimbogibbo Member

    these are both 027 scale one running on a railpower 1300 and the other is running on a mrc 280.
  8. Renovo PPR

    Renovo PPR Just a Farmer

    You are in fact underpowered with both of these. The first is for smaller trains such as N and HO. The second is listed for O but it is best for HO and N.

    The TECH 4 600 might of been a better choice.
  9. Renovo PPR

    Renovo PPR Just a Farmer

Share This Page