Decoder in an MDC Roundhouse 2-8-0

Discussion in 'DCC & Electronics' started by Racharg, May 28, 2004.

  1. Racharg

    Racharg Member

    I'm a DCC newbie. My first decoder install on an atlas gp35 went well and after much squeezing and shaving, I've managed to install a decoder in the tender of an MDC roundouse 2-8-0. Now I seem to have developed a short somewhere. Is there a tried and true method of determining the cause of the short? Is there a way to test the functionality of the chip once it is wired in to make sure that it is working properly? The light function works fine but there's no motor rotation on either DCC or DC track power. And as a final open ended question ;) , are there any tips out there that would help out?

  2. jwmurrayjr

    jwmurrayjr Member


    Was the loco built from a kit?

    I recently purchased a couple of RTR MDC Old-time 2-6-0s and a 2-8-0. I had a problems that sounds very similar to yours with one of the 2-6-0s. When I returned it to MDC they diagnosed "an unusual electrical problem in the manufacturing".

    All of these locos came with a label cautioning the user to check the the DCC plug for reversed wiring. Two if the locos (one 2-6-0 and one 2-8-0) had this problem. The loco that I tried the decoder in did not have that particular problem but apparently had another.

    I kept only the 2-8-0 but I have not installed a decoder in it yet.
  3. Racharg

    Racharg Member

    Sorry, guess I should have mentioned that it's n-scale ready to roll with no socket
  4. zeeglen

    zeeglen Member

    Do you have a VOM (volt -ohm-milliampmeter)? This tool is a neccessity for troubleshooting this kind of problem, the very cheapest is all you need - about $15. This can measure voltage to the motor, current draw and resistance to sniff out a short by disconnecting wires until the short disappears.

    A visual inspection can turn up things like wires with insulation stripped too far back, letting their exposed conductors touch things they should not touch such as other wires or nearby metal. Metal filings and shavings can get stuck between two power points and cause shorts too. Or the decoder pcb may have shifted position and is touching metal where it shouldn't. Good luck tracking this down.
  5. Russ Bellinis

    Russ Bellinis Active Member

    Make sure you motor is isolated from the frame of the locomotive.
  6. Racharg

    Racharg Member

    Well, after poking and proding every permutation and combination with a VOM, there is no short that I can find. Looks like the chip is caput. Not sure if I managed to let the magic smoke out of it as I neglected to test its functionality before the installation. Luckily, it's a TCS M1 chip and they have a "Goof Proof" waranty that I'm about to test. According to them, even if you accidentally fry the chip, you can send it in to them and they will either repair or replace it for you. Considering the M1's tiny size I'm not sure how they'd go about repairing it though. Anyways, thanks for the help and I'll let you know how the replacement chip works out
  7. shaygetz

    shaygetz Active Member

    I had a similar problem in one of my first installs. It turned out that the chip was shorting out on the motor casing. By wrapping it in electrical tape, the problem was fixed. Thankfully, I didn't smoke the chip in the process either.

Share This Page