Athearn Challenger - Bad news.

Discussion in 'N / Z Scale Model Trains' started by TrainNut, Mar 22, 2007.

  1. TrainNut

    TrainNut Ditat Deus

    Well, I guess it seemed to good to be true. My new Challenger came to a screeching halt today... quite literally. I was operating it on DC, just watching it chug around the layout quite contently when all of a sudden, the squealing brakes sound effect kicked in and so did the momentum stop. After it had come to a complete stop, it did a nice little steam blow sound and just sat there. I thought, "hmmm that's weird", and turned the throttle off and back on. Nothing. So I turned the power switch off and back on and then applied a little throttle. Not only did it respond, but it did so as if it were on nitrous. The chug chug sounded as if it was doing 200mph even though the engine was doing a scale 50mph or so. I then hooked it up to DCC to see what the hey and all it wanted to do was sit there and click or run at top speed. Called my LHS and they told me to bring it in tomorrow so they can "have a look."
  2. UP SD40-2

    UP SD40-2 Senior Member

    TrainNut:wave:, i have two Athearn Challengers(HO scale). i am puzzled by your problem, fortunately, i have had NO problems with mine. i ONLY run DCC;). i am guessing they are set up the same, and the CV's would be the same, though i am NOT sure:oops:. Have you tried setting the CV29 to the value of 2? if the N version is the same as the HO scale versions, that should set it back to factory default;). sorry, but thats all i got:oops:. hope that helps.:D -Deano [​IMG]
  3. Biased turkey

    Biased turkey Active Member

    TrainNut, if you run the locomotive in DCC, don't you have an option to reset all the parameters to the default value ? I would try that first,or maybe just changing the adress.
  4. TrainNut

    TrainNut Ditat Deus

    You know, I have not changed anything on it. It is still running as it was straight out of the box. It almost seems like there is a short somewhere and I am afraid that if I start messing around with it, that will give Athearn a reason to put the blame on me. It just stopped and it shouldn't have. It should not require any Mickey Mousing around from me to get it to run again. Thanks for the input. We'll see what the LHS has to say today but I have a feeling I will be placing a call to Athearn later today.
  5. woodone

    woodone Member

    Wow!!! From what I have read about all the Challengers just stoping for no reason. Got to be a problem somewhere. There was a Challenger that had stoped working about the time you first got yours, wonder what ever happened to that one. Good luck with the LHS, they can get in touch with Athearn. Hope they can fix the problem. I am holding off on getting one untill all these problems go away.
  6. TrainNut

    TrainNut Ditat Deus

    Last I heard, The Freight Yard has sold 48 of these so far and mine is the first of the ones they have sold to have problems.
  7. toptrain1

    toptrain1 Member

    The chip is a little computer. Did you try a reboot. Taking it off the track then test running another locomotive. After that return it to the track checking it well for shorts or if a a pick up truck has spunn around cousing a short. If it seams allright apply the power again running it on just DC. If you don't at the hobby shop it may just run Ok.
  8. I'm sorry to hear of your trouble, but at the same time, if it really happened the way you say, I think it's so cool that even when the problem occurred, all the sound effects highlighted the event in proper sequece. The only thing that would have been cooler would be if this was one of the SD45T-2s with full SP light package, and the red emergency lights came on
  9. woodone

    woodone Member

    Sorry to here about the troubles. If you recall there was a Natankman that had some problems. They sounded much like the ones your are having. Do you know what ever happened to that one?
    A speedy recovery to the Challenger.
  10. TrainNut

    TrainNut Ditat Deus

    I tried your idea of troubleshooting to no avail. All it wants to do now is sit there and click.
    Yep, that is exactly how it happened. I thought it was pretty cool too the way it did it but it was also very uncool when it would not restart again. I found it interesting that it shut down the way it did as opposed to stopping instantaneously.
    I never heard any responses back from that other guy that had similar problems. Hopefully he has had them resolved.

    I took it back to the LHS shop today and they put it up on the layout where all it wanted to do was click for them too. Upon removal from the track, it was obvious there was a dead short somewhere as the tender was very hot after only sitting on the track for a minute or so. They told me that these things are in high demand but they had one more coming in from somewhere and they would put my name on it and they would send this one back.
    Upon racking my brain for any possible reason this may have been my fault, I can only come up with two things...
    1. In the manual, it says to not use a high powered controller as it may damage the electrical componenets of the engine. My DC controller is a Tech II and while I did not check the amperage specs as required by the engine, that could be a possibility. All of my other DCC engines run fine off that controller though.
    2. I was splicing some track that same day and was grinding some ends flat on the rails with my Dremel tool. I guess, somehow, after I vacuumed, I could have missed a small enough piece of a metal filing and it somehow could have gotten up inside the tender shorting something out. Unlikely I think but possible.
    I sure would like to know what happened as I don't want the same thing to happen to the next one.
  11. nscaler711

    nscaler711 Member

    if you think thats wierd i bought a bachmann 2-6-2 the day after Christmas and ran it for 10 min. at 40 smph and all of a suden it stopped then something popped off, the drivers main connecting rod , then shot forward then jumped the rails 2 sec after all that.
  12. TrainNut

    TrainNut Ditat Deus


    The saga continues. As many of you have probably read in a similar thread, my first Challenger was sent back by the LHS and I finally received a replacement. Somewhat fearful of the same thing happening to the second one, I did not even take it out of the box until this weekend. I took it up north a little (Prescott, AZ) to show it off to my dad and some friends. We set up two pieces of flex track, hooked it up to my Digitrax Zephyr controller ANDDDDDDDDDDD nothing. It made sounds and all but would not budge. What a disappointment. Upon arriving home, I put it on the home layout to do a double check before I returned yet another Challenger to the LHS. It did the same thing. I jiggled it back and forth a little and noticed that the second set of drivers were not budging. I jiggled a little more and something gave way. Being the hopeful person that I am, I turned the throttle up a little and lo'n'behold, thar she goes. Called up my LHS to report the problem and the solution and they said that they felt it would be beneficial to test each and every one before it left the store. PHEW! Now unfortunately, I am left with the impression of, "How long will it be until this one breaks?"
  13. nscaler711

    nscaler711 Member

    personaly i would wait to get another untill all of the bugs have been fixed....but i'd be to obsessed with that locomotive and not want to that case its probably a good thing that i model the 21st century, modern day, equipment. cause to tell u the truth i cant afford an Athrean Challenger....its too expensive
  14. trainnut65

    trainnut65 Member

    After reading this post. I think you mite have some flashing in the trucks.
    As much as one of the little gems cost they should make sure there is not anything in the trucks before shipping them out.
  15. TrainNut

    TrainNut Ditat Deus

    That is definitely something I will be checking on the current Challenger before I send it back. However, this locomotive was sent back a long time ago, probably fixed, and sent back out to some unfortunate individual who has not got a clue.

Share This Page