UMC2 Problems

Discussion in 'Software' started by Plastic Bonsai, May 14, 2008.

  1. I've started this to at least let the Bucc thread die in peace.

    Card Models is UMC2's home and it's very happy here with lots of nice, friendly people who can now use this thread to highlight any problems they have with it and suggest any new features it could have.

    Some have been unfortunate in not getting the program to start straight away. So far the most common problems are that the program or the model is in a long directory path or that the path contains "." which really confuses it when trying to identify the file type.

    So if at first you don't succeed: Try short directory paths with no "." in them and this might be a very short thread:mrgreen:!
  2. Gearz

    Gearz Member

    Sorry PB.. I'm code challenged, so I can only explain (stuff) in laymen's terms ~ I'm not really sure if this one is a coding problem, I'm simply missing a step /setting, or its specific to .mdl format.

    Exported materials issue ~ when exporting to .mqo format.

    e.g. an imported .mdl model may have X number of textures. When exported to .mqo format ( and opened in META) there seems to be multiples of each texture + several redundant textures listed in META's materials properties.. its not really a major concern, it just makes editing and working with the textures a little more complex. Any insight on this ?.

    + Possible tip for UMC2 users.

    I can't say if its specific to my system, however, I've resolved several exporting hiccups by rescaling a model down by .1 or smaller before exporting (exporting to .mqo format in particular)

    Thanks for starting this thread PB !
  3. Hi Gearz

    Edit->Tidy Materials should reduce the material and texture count to the essentials. The .mdls generally have textures for each components and they get repeated.

    If you are patient then Edit->Tidy should do this as well as well as it reducing the vertex count which might make the model more whole.

    When I export to mqo I invariably have to re-scale as the mdls are huge. I select the wingspan (y) to be 200 using Transform-> Scale

    I think I have fixed a bug which makes the .mqo now exportable directly to Peparuka.
  4. sergbuto

    sergbuto New Member

    Where can one get UMC2 to come up with problems if any? :)
  5. Gearz

    Gearz Member

    PB ~ help! ~ I'm trying to ramp my UMC2 skills, however a minor hick-up is giving me grief.

    * Regardless of menu selection or key selection, a hand ( cursor) is always present in the model window that rotates the model with cursor movement. Its hard to select a panel when it keeps dodging the cursor, so how do you de-activate it / stop the model from rotating with cursor movement.? The answer is probably right under my nose but I can't find any obvious menu command/ key / key combo..
  6. This is the perfect time to panic!

    Sorry Gearz

    But that is what the program does at the moment. It used to defeat me when I tried to fix this but...

    Spookily I tried a solution to it last Friday, the only significant PC time I get usually, where the model/observer only moved if the left button is pressed so you can turn through greater than 360. I found I had put in a feature which confounded me. It now appears to work OK but I have to slightly re-jig the activation logic that the left key uses now. It also felt a bit weird as I am so used to the feature.

    I hope I can reproduce the standard model view actions of pep and meta but I like the moving observer option as well.

    A few of the edit options are available through key presses and one or two menus pop up on left key press to ease the current problem.

    And before you try it the latest beta program doesn't let you add panels using the on screen editing - that does work in 1.3 though.
  7. Nothing

    Nothing Longtime Member

    when i load a mdl file the parts are scattered.
    when i save as a .mqo and open in meta it looks like im looking at it through a fish bowl.
    any ideas or am i just crazy?
  8. Nothing

    Nothing Longtime Member

    ok i figuredout i need to rescale.

    i have a plane i need to convert to .mqo. umc will load the mdl file but every time i try to save it umc crashes. do you know why?
  9. Ummm.... There might be a "." or possibly a " " (space) in the directory structure names or the folder names are too long or there might be some bad numbers in the file.... If the model shows up then it is probably a file/folder name/length issue. Try saving to a higher/shorter directory. If no luck send me a link and I'll see what I can do.

    And a lot of later .mdls end up in bits - sometimes you can piece them together but I should try and figure how I've got the transforms wrong.
  10. Nothing

    Nothing Longtime Member

    well the utility is on my desktop and the file is on my desktop. is that the file path you are talking about?

  11. Oooops no, sorry I meant the file path of the .mdl file. In order to get the model to show after conversion it is written out to an undo.dat file in the same directory as the .mdl file and then it is read back in. This has worked in your case but when you save it yourself there is a problem with it when the whole folder structure is added to the file name.

    If the conversion takes some time then you should be able to rename the undo.dat into a .mod file and load it directly but it probably needs moving to a shorter filepath.

    If UMC2 doesn't produce the model then it is sometimes worth having a look at the undo.dat file - it might have a problem with a texture name or have some really strange numbers in it.

    Another tip is when converting .mdl files put them in a directory without their textures as invariably it has problems with the later .bmp files and it takes a while to OK every texture file error notification.
  12. Nothing

    Nothing Longtime Member

    ok i understand. i hate to be a pain but i really would like to see this work.

    pulling the .mdl out keeps it from crashing. but saving to .mqo gives a file with no info. no undo file. if i save as a .mod file i get a mpeg file. if i save as obj iget a file with nothing visible.

    if i move the file to its own folder and save to .mqo i get a undo file that is a nero showtime file and the .mqo fails to load.
  13. Gearz

    Gearz Member

    Thank you for the answer on the model mov PB.. Its no big problem, I'm kind of use to it now, although an option to have alternate view methods would be handy.

    Gaaaarrrrrhhhh...... .mdl format is making me tear my hair out.wall1 What a B******* of a format!! I fully realise it wasn't intended to be errrr..'edit-able' ..however with the wealth of worthy subjects available, its like waving a steak dinner in front of a starving man. After scoping all the technical blurb I could find, and importing a zillion models into UMC2, I still cant figure out how one format seems to have so many different configurations.. It seems to depend more on which program the models were created in before they were converted into .mdl format. eg Models created in Gmax and then converted into .mdl makes UMC2 crash ( on my system) * I've tried all the suggestions you've made.

    I know its a big ask PB but is ANY way you could tweak UMC2's mdl importer to be a little more tolerant. I MUST have those Luft'46
  14. Yeah the GMAX versions are very dodgy. All the other 3D formats I have dealt with have some simple logic to them. The .mdl format is really something else. I can only wonder at the codes that work with them. I am pondering having a go from scratch ... again!. There are some simple elements that can be extracted - what really gives the pain is the myriad of transforms. If I ignore them I'll probably get a tarball of parts but it may be better than nothing. Speaking of which..

    We haven't figured out what Nothing's problem was.The .mdl translated straightaway with 1.3 on my machine so that got him on his way at least.
  15. Nothing

    Nothing Longtime Member

    just sos you know i am having some success. with fs files from 2002. 2004 are mostly no gos. but some of the 2002s wont go. i apreciate you help.

Share This Page