t maxx wont start

Discussion in 'RC General & Getting Started' started by andydrivestmaxx, Jun 17, 2005.

Thread Status:
Not open for further replies.
  1. andydrivestmaxx

    andydrivestmaxx New Member

    I bought a t maxx the other day,I put new batterys in the car,tested the glo plug and glow plug stator which both work,it had the ez start replaced with pull start and there is no way to prime it so I put a few drops of fuel in the carb and still no go and the pull start is getting harder to pull,it doesnt appear to be taking any gas into the engine,what the problem,I put the plug stator on the glo plug and pull the pull start and it just doesnt start! Both the controllor and car are on.
  2. dj6666969

    dj6666969 Active Member

    usely on Tmaxx's there is alittle pump right on the tank, this is used to prime it, unless there is a differen't tank on it. Check the fuel lines for any holes. Cover the exhaust pipe and carb and then pull on the pull start and see if any fuel comes up the lines. What engine is in it? For the trx .15 the setting are 2 and a half turns out from fully closed for the HIGH SPEED NEEDLE. The low speed should be flush and the idle should just barly be open..
  3. andydrivestmaxx

    andydrivestmaxx New Member

    it has a new tank,this t maxx has had some mods apparently
  4. dj6666969

    dj6666969 Active Member

    is there alittle primer on the top of it? Did you try what I sadif b4 so primp it. TAke out the glowplug, tip it upside down and then pull the pullstart to drain any extra fuel out of it.
  5. andydrivestmaxx

    andydrivestmaxx New Member

    SHE RUNS! I covered the exuast and pulled a few times and it ran,but it wont take any gas in so it only runs for a few seconds,and I noticed that the car doesnt react when I do anything with the remote,I changed the batterys and still no go,connecting 2 parts of the fuel lines is a round metal thing,but the fuel will go through when I cover the exuast and pull,the metal gear in the middle spins and sometimes the car wants to take off when I prime it alot,
  6. dj6666969

    dj6666969 Active Member

    If there is something in the fuel lines what it sounds like it is a in line fuel filter. IF you turn on the tmaxx and then controller and nothing happenes, and you have put new batts in the controller and then truck you might need new crystals or something in that area. Is it the stock reciver and radio? Did you have the attena all the way up on the radio?
  7. andydrivestmaxx

    andydrivestmaxx New Member

    it is the oringinal controller,the batterys in it have been changed,the truck has 2 somewhat new AAs in it(for the on/off switch)this car was said to have run,how do I know what channel the controller should be on?
  8. andydrivestmaxx

    andydrivestmaxx New Member

    the pull start is very hard to pull now
  9. dj6666969

    dj6666969 Active Member

    its flooded, take out the glow plug, turn it unside down and pull the pullstart
  10. redheat

    redheat Member

    To prime it remove the pressure line from the pipe and blow into it , use a fully carged glow plug heater and start cranking should start right up. RED
  11. socks

    socks New Member

    tmaxxs are a piece of crap my savage blows them to shreds on racedays
  12. dj6666969

    dj6666969 Active Member

    of course it woulkd, even a 2.5 tmaxx is about the same size as a .18, while a Savage has a .21 or a .25. If you put a .21 with a conversion kit in a Tmaxx it would fair pretty good with the savage.
  13. redheat

    redheat Member

    Small v Big Block do the math . Socks your logic means nothing because it is pointless .....Apples to oranges, RED
Thread Status:
Not open for further replies.

Share This Page