Prodigy advance^2 with older Atlas Master locos? *UPDATE*

Discussion in 'DCC & Electronics' started by thedowneaster, Jan 5, 2010.

  1. thedowneaster

    thedowneaster Brakeman

    I just received a new MRC Prodigy Advance^2. The system works very well with my Bachmann 44 tonner. However, I have 4 older Atlas GP40 master series engines which will not respond at all. These are dual mode decoder-equiped engines which have been used in analog mode for about a year.

    So far:
    I have switched the circuit plugs from analog to digital and I have assumed a default address of 3 for all of them.
    Any idea what I could be doing wrong?

    Thanks for any help!
  2. thedowneaster

    thedowneaster Brakeman

    Problem Solved! :mrgreen:
    I discovered last night that the addresses on my older Atlas locomotives were derived from the actual painted number on the side of the cab. BUT here's the trick... they used only the last 2-digits. That way the loco comes out of the box with a unique address that's still considered a "short-address."

    I am super-happy with my Prodigy Advanced^2. The system is easy to install, and very user-friendly.
    My locomotives are running smoother and quieter than ever. I can't wait to get decoders and sound in some of my older locos...My old U33C collection, for instance, is just begging to join the digital days... and despite their red-box age, they seem easy to convert too! Now all I need is a micro-sized smoke system that produces dark GE soot.
  3. Calculon

    Calculon New Member


    Good to know. As a newbie to model railroading I am currently in hoover mode (sucking in as much information as possible). Posts like yours provide me with a starting point to do research on a product that members recommend.


Share This Page