Problem even unfolding a 3DS cube in Pepakura?

Discussion in 'Tips, Tutorials & Tools' started by BazookaJo, Jun 2, 2006.

  1. BazookaJo

    BazookaJo Member

    Okay, going right back to basics.

    Have created a pure simple cube (4 vertices) in 3DS and exported it.

    Opened the file in pepakura. all I see in the 3D model window is a single square representing one of the faces of the cube, with all 4 lines representing the cube shown in red.

    I run 'Create Development' and what I get in the Development Window is 3 complete sides, and 6 sets of two triangles.

    Anyone have any idea what is going wrong, or what I need to do to fix it?

    Do 3DS and Pepakura have compatilbility issues and should I just move to Metasequoia (if so, anyone got a link?).

    Best Regards

  2. cgutzmer

    cgutzmer Guest

  3. hpept

    hpept Member

    there is nothing wrong. This is pretty usual, as the "create development" automatic function barely obtains acceptable results with only the simplest shapes (not in your case, anyway...:grin:). All you have to do is to figure out which and where all the triangles are and go. You can use the function to join the edges, click on an edge of a solitary triangle. A red line will appear pointing at the mate side. Just click and the part will run to its correct position. This can be a very time consuming, but it's the only way (at least the one i know) to obtain a correct development.
  4. keith

    keith Member

    What you could do until you figure out how to do it in 3dsmax is to use metasequoia as a tidying tool to 'join closed vertices'.
    metasequoia docs are here :-

    3dsmax should have no problems exporting a good model to pepakura, you simply have to know what is wrong with your current models as it could be a number of things.

    Any chance of uploading your simple cube model somewhere so we can look at it and tell you whats wrong?

  5. SteveM

    SteveM Member

    I don't know 3DS, and I don't mean to be a smart@$$, but doesn't a cube have 8 vertices (i.e. "corners")?
  6. BazookaJo

    BazookaJo Member

    Cheers for the links Keith & cgutzmer.

    I would if I could figure out why WS_FTP isn't working at the moment:cry: Could I email it to you?

    Sorry, total noob. Do you mean the 'Join surface' tool? And do I click on the edge in the model window or the development window (as it happens no red lines appear when i click in either window).

    Just out of interest, before I click 'Create Development' the cube has red lines on each edge including the lines which show where the square faces are cut into triangles. I'm assuming the 'Specify Cut Edge' and 'Specify Edge not to Cut' should be available here, but these don't seem to do anything either:-?

    It's been a long night.
  7. BazookaJo

    BazookaJo Member

    Okay, there is def something up with what I'm doing.

    Downloaded Metasequoia and opened the cube, but there's nothing there.

    Nearly 1am - had enough - off to bed.

  8. wunwinglow

    wunwinglow Active Member

    Somehow, you have to 'weld' the vertices. It sounds as if the 'box' is formed of 6 seperate rectangles that just happen to have coincident vertices. You need to tell the mesh that each corner is the same vertex, being used by the three adjacent surfaces.

    I don't know 3DS so I haven't a clue what the commands are for this, but most mesh modellers will have an equivalent control somewhere! Then Pepekura will understand the triangles are part of a whole and unfold them , rather than seperating them into individual triangles; which, unwelded, is exactly what they are!

    Tim P
  9. BazookaJo

    BazookaJo Member

    I hear what you're saying, and I'll keep looking around.

    I've also finally managed to FTP my 3DS test cube to the web (clowns at virgin have screwed up my viewing permissions), so if anyone can have a look at it via Pepakura and Metasequoia (where it wont appear at all) I'd most appreciate it.

    If I've done this wrong let me know.

  10. BazookaJo

    BazookaJo Member

  11. wunwinglow

    wunwinglow Active Member

  12. BazookaJo

    BazookaJo Member

    Cheers Wunwinglow

    I'll trawl the 3DS boards and see if I can find out what the crack is.

    Meanwhile, anyone any idea why Metasequoia can't see it at all?
  13. barry

    barry Active Member


    If you import to metaseq choose "select all" then under object click "Join closed vertices" save the file as metaseq open it in pepakura and you get this try exporting your file in dxf.


  14. keith

    keith Member

    yes i agree you need to 'weld' the faces/vertices :)
    I'll see what i can find.

    It WILL load in metasequoia, it's just you can't see it.
    Take metasequoia out of basic mode, if you haven't already. (file->basic mode)

    At the import prompt you need to 'multiply' by 0.1
    Then in the top menu ....edit->select all
    then again in the top menu attribute -> fit to view
    then again in the top menu attribute -> set center of rotation
    then again in the top menu object -> join closed vertices.
    save it.
    you can then play with the wire tool in the left menu under commands.

    or just do what Barry said because you don't really need to see it do you? :)

  15. BazookaJo

    BazookaJo Member

    Ahhh:twisted: - now we're in business.

    Major thanks to everyone, I can now press on. Though if anyone figures out the equivalent in 3DS please let me know.

    Best regards

  16. BazookaJo

    BazookaJo Member

    Okay, still having problems with Metasequoia.

    Can join closed vertices fine, but sometimes it alters the mesh a little so I've gone through Keith's instructions step by step to have a play with the mesh, but it still doesn't show up on my screen. What I get is the file below:

    Could someone have a quick glance and see if I've got some dumb default setting on my version that's messing it up?

    Thanks again

  17. keith

    keith Member

    see attached image, play with the circled buttons.
    you also need to do the 'select all' and 'fit to view' again.

    With the join closed vertices, you don't have to type a number in, if you leave it at 0.00 it will remove all the repeated vertices, if you put a number in it will joined all vertices within that distance, changing your model.

    do a google search for '3d studio weld vertices'


    Attached Files:

  18. BazookaJo

    BazookaJo Member


    Major thanks Keith. Started having a bit more of a successfull play with Pepakura today - Just one perhaps stupid question:roll:

    How do you get your model in Pepakura to be actual size? Currently it doesn't seem to be the same size as the 3DS model I've created.
  19. barry

    barry Active Member

    Crude but effective print it measure it find the multiplication factor to size to your model when pepa has unfolded it in the DEveloped view window menu select scaletospecifiedsize read the numbe in the box. If it is 10 and you calculated 15 then put 15 in the box. Now if you want to do a few parts at a time you can use this as a constant. Remember though that if for example you have designed a ship you must first unfold the whole thing for a start number. Then pick an easy part out.
  20. BazookaJo

    BazookaJo Member

    Cheers Barry I'll give it a whirl, but why do you have to unfold the whole model first?

    If I export parts separately will Pep not scale each one by the same amount, or is the problem that it reduces/enlarges each bit by whichever seems to fit on the page best?

    Best regards


Share This Page