ok so i'm not get any fuel???

Discussion in 'RC Offroad Forum' started by spacin, Jul 13, 2004.

Thread Status:
Not open for further replies.
  1. spacin

    spacin New Member

    why oh why am i not getting any fuel into my carb?

    losi GTX mach.15 engine

    just replaced old fuel cell with a new one ... they moved the vaccum hole to the top of the fuel cap it gets suction when i am trying to prime it but as soon as i let my finger of the exhaust the fuel goes back into the cell[}:)]

    might it be that the new placement of the vaccum is just completely wrong? or is it just me?? hehe
  2. When you cover the exhaust stinger, you are creating a suction throughout the engine, exhaust, fuel tank etc. If a tube is loose or you have bad engine compression, the suction would be able to hold the fuel in your carb. Check all your fuel line connections and check your engine for compression.
  3. redheat

    redheat Member

    either you dont have enough compression to draw vaccum or you need to clean your carb. , check the fitting on the pipe make sure that it is clear of crap.
  4. jackal575

    jackal575 Member

    i would also check for air leaks around the carb
  5. atc1100rider

    atc1100rider Member

    or air leaks around the primer
  6. redheat

    redheat Member

    Dis connect line going into carb. next disconnect line from pipe blow into pressure line fuel should go from tank to fuel line and out. Next hook lines back up remove air filter do same as above look in throat of carb.and blow into pressure line if no fuel remove inlet nipple clean,H/S needle,clean replace all and try starting. Do you use a fuel filter? If so clean or replace they do go bad.
Thread Status:
Not open for further replies.

Share This Page