nitro star-25 BROKEN

Discussion in 'RC Offroad Forum' started by alisar70, Nov 24, 2004.

Thread Status:
Not open for further replies.
  1. alisar70

    alisar70 Member

    my engine is completetly As-s it needs a new blackplate cause the 1 i got has totally got mashed up
    so im going to get a new blackpalte in a moonth or so

    SAVAGE 25 engines are CRAP
  2. jlmoreno911

    jlmoreno911 Member

    you got some bad luck, buddy...

    Mine has been working fine with no problems...
  3. dj6666969

    dj6666969 Active Member

    I just think you don't know what ur doing my friend. That engine shouldn't have done that for a #@$% of along time if ever!~
  4. rustler

    rustler Member

    i've had my savage 25 for about 6months and nothing has happened to my engine as a matter of fact that is the only thing that hasnt given me any trouble
  5. monsterrcbuilder04

    monsterrcbuilder04 Active Member

    i know people with liek 5 gollons through theres and still running strong...i'd say reliable engine if broken in properly
  6. dj6666969

    dj6666969 Active Member

    I think he didn't break it in properly
  7. Justin_E

    Justin_E Member

    i think so too lol
  8. alisar70

    alisar70 Member

    i did break the engine in....3 tanks of heat cycle then slowly to full throttle

  9. dj6666969

    dj6666969 Active Member

    hmm were u letting it cool down? Leting it cool down it a must! And also when u were running it did it ever get up to something and couldn't move and then you tryed to hit the throttle for it to get away from that object? I don't really know I guess maybe you just had a disfunctional engine, but I don't see those kind of things happen often.
  10. gaz_r36

    gaz_r36 Member

    i think he doesnt no wot he is do
  11. dj6666969

    dj6666969 Active Member

    maybe maybe not
  12. gaz_r36

    gaz_r36 Member

    how many tanks should u use 2 run them in
  13. dj6666969

    dj6666969 Active Member

    umm probly 4 to 7 tanks.
  14. alisar70

    alisar70 Member

    i used 8 tanks for the whole run in procedure and stuff

    i did what it said on the dvd
  15. danielh89

    danielh89 Member

    i think you got a dogey engine
  16. dj6666969

    dj6666969 Active Member

    send it to HPI then if it is a bad run of the bunch!
  17. gaz_r36

    gaz_r36 Member

    or he just didnt run it in propley because he is ***
  18. alisar70

    alisar70 Member

    hey man shut up theres children on this on this forum

    BY the way peopðle ive bought a 26 engine will take pictures of it on thursday and post it on here with the mods i addeed to the savage 25
  19. gaz_r36

    gaz_r36 Member

    im a child if u class 15 as 1
Thread Status:
Not open for further replies.

Share This Page