New ESC isn't doing a thing!?!?

Discussion in 'RC General & Getting Started' started by bandit1, Jan 5, 2004.

Thread Status:
Not open for further replies.
  1. bandit1

    bandit1 Member

    I just got a Streak 12T limit ESC. I hooked it up to my reciever, hooked it up to the FULLY CHARGED battery, turned on my radio, then i went to flip the switch and not a thing happend. Anyone know anything about this. And if u need anymore info, i try to get it to u.

    By the way, im not sure if this is a factor but i also have a new motor on the truck but its within the limit of the ESC.

    Any help would be appriciated.
  2. timrock

    timrock Active Member

    you hooked up the battery and the lights on the ESC didnt come on either?when you turn the radio on you should see the green light and/or the flashing red light.if the thing doesnt work you`er going to have to send it back for another one.
  3. bandit1

    bandit1 Member

    ya, thats wat was so wierd about it. I thought it was just because my radio wasnt on the first time it didnt light up, then i turned on the radio and still nothing happend. so it looks like ill be sending it back. question on that tho,probobly a dumb one but do i send it back to towerhobbies or Duracrap?(duratrax,haha...)thanks.
  4. Steve M

    Steve M Member

    Did you run through the One-Touch setup feature?
  5. timrock

    timrock Active Member

    im pretty sure the lights should come on even before you go to set it up.
    Call Tower and ask them.they might send you another one in exchange for that one.if not then you will have to use the warranty and send it to Duratrax.make sure it isnt the plugs or somthing like that before you take the time to go through all of that.i just bought two of those Streak ESCs and they work great.
  6. bandit1

    bandit1 Member

    SteveM:When i first got the ESC before i read the manuial on how to set it up, i just wanted to see that it worked, to do that i just hooked up battery to it and it worked awesome. Thats what is so weird about it, it worked fine the first time i got it, but then i went to use it again it did nothing.
    timrock:well its good to hear that the ones u have work good. i still belive in the esc its just getting one that works!!Thanks on the exchange answer.
  7. timrock

    timrock Active Member

    bandit.those ESCs work great.if yours worked at first and now it doesnt,you might have done somthing wrong.i dont know.i do know that,recently,a guy in this forum posted pics of his Stampede.nice rims and tires,nicely painted body.good looking truck.he also had a close up pic of the motor.i saw that his motor wires were touching eachother all the way down to the end bell of the motor.i replyed and told him that if the motor gets hot enough,it can burn through the insulation of the wire connecting the polarities of the motor wire and ruin the ESC.
    the +wire was touching the tab of the - on the motor.the insulation was the only thing seperating them.
Thread Status:
Not open for further replies.

Share This Page