Need help with servo glitch...

Discussion in 'RC General & Getting Started' started by NewRider, Dec 29, 2003.

Thread Status:
Not open for further replies.
  1. NewRider

    NewRider New Member

    Hello,
    I have an RC10T3 with JR Python control equipment and a Dynamite ESC. I can dial in my throttle trim and everything is fine. A few minutes later I can set the controller down a moment while rummaging through the tool box and the car starts pulsing again. Its a neverending trim battle. This happens with battery at full charge and controller batteries at full charge. Any suggestions would be greatly appreciated.

    Sincerely,
    NewRider
  2. timrock

    timrock Active Member

    if you put the transmitter down right next to the car while the radio is on,it is bound to do that.if you want to leave it on and put the controller down,dont put it so close to the car.also when putting the tranmitter down,stand it up so the anttenna is vertical and higher than the reciever/car.
    if it still glitches let me know.
  3. NewRider

    NewRider New Member

    timrock,
    Thanks for your reply. I do always place the controller upright when I set it down. Im not setting the controller right next to the truck. My tool bench is about 10 feet from the track where the truck was sitting when I first noticed the throttle servo glitching. Thanks in advance for your input.

    Sincerely,
    NewRider
  4. timrock

    timrock Active Member

    check the entire car for loose bolts or anything metal that has any play in it.believe it or not,this can cause glitching too.
Thread Status:
Not open for further replies.

Share This Page