need help please (new at this)

Discussion in 'RC General & Getting Started' started by mcgldrck2, Jan 2, 2004.

Thread Status:
Not open for further replies.
  1. mcgldrck2

    mcgldrck2 New Member

    i have a Tamiya black foot electric truck that i got with some problems. It came with a kyosho pulser pro-2000 transmitter,wich came as a package the guy had got for the truck(a transmitter, receiver,2 servos)well the problem is that when i put brand new batteries in the transmitter it doesnt come on but does if i plug it up to the wall,well when i plug in the batt pack for the truck the truck takes off full blast,even with the truck switch off but even though the trns is on when pluged in it doesnt work the truck.
    please help.......
  2. timrock

    timrock Active Member

    the problem is in the battery magazine/holder in your transmitter.it is not making full contact with the batteries.
    the truck takes off just as it might if the transmitter is off.
    never turn on the ESC with a pack plugged in if the tranmitter is off.if the ESC is turned off and the truck takes off anyway,then the switch doesnt work on the ESC.
  3. And remember, if you have a mechanical speed control in a car and you plug in the battery without turning on the transmitter or reciever, it will go full throttle. Any time you plug in a new battery, with an MSC that is still on the 3rd and final speed, you should always turn on your transmitter and receiver and than plug in the battery so the MSC will switch back to Neutral
  4. bandit1

    bandit1 Member

    haha, trash, sound familiar, ive done that many times before!!
  5. Aussie_in_NJ

    Aussie_in_NJ New Member

    you can also flip the car on it's side while you connect the battery that way the differentials kick in as the MSC is moved back to neutral by the servo [if you have a MSC with BEC]
Thread Status:
Not open for further replies.

Share This Page