NEED BIG HELP!!!!!!!!!!!!!!!!

Discussion in 'RC Offroad Forum' started by xerox, Feb 19, 2005.

Thread Status:
Not open for further replies.
  1. xerox

    xerox Member

    i need a lot of help i just bought a new savage ss and i tryied to break it in and when i did the truck would go fast for two seconds then i would leave the trotle open for two sec's and when i let go it would die also i cant get the truck to go higher temperature them 99 for some reason also when i lean out the bottom end it starts to move on its own then i would richen it up and then it would go fast agian for two sec then i would let go of the gas and it wouyld die quick.
    please any help would be appreated also i have broken in engines in before but they were small blocks not big blocks so i am not use to it so can you help me.
  2. digdug72

    digdug72 Member

    is your idle set correctly?
  3. thegoonman

    thegoonman New Member

    When u break it in you will want to have it rich. The low end needle does not matter much, it just sets the response from the controller.

    Not saying that this will work but sometimes engines just need to get going, you could hold the wheels off the ground to get the engine warmed up. Then after a bit the engine will be running more stable. This is just a suggestion, i have done this before and has worked good but not sure for you.
  4. monsterrcbuilder04

    monsterrcbuilder04 Active Member

    for the first tank i ussually just leave the truck sitting at idle. i think you might need to adjust your idle a bit and maybe your high end needle
Thread Status:
Not open for further replies.

Share This Page