Memory Loss?

Discussion in 'DCC & Electronics' started by green_elite_cab, Jul 29, 2007.

  1. green_elite_cab

    green_elite_cab Keep It Moving!


    I've been having problems with DH163AT decoders. apperently, every other time or so that i turn the layout on, the decoders do not respond to anything (not even 0003). the only thing that seems to work is to put them on the program track, reset them, and reprogram them, and then a few days later, gone again. I've only programmed the long adresses (which i have finally figured out) and set CV29 to 36.

    I've also noticed that the train has stopped responding mid run, or it lags. I'll tell one locomotive to go full speed, and it will crawl, then jump to a faster speed, then it jumps again and hits the gas, in like, 40 seconds, rather than just accelerating as the throttle goes up. It will also keep rolling after i tell it to stop (and its not momentum, it keeps rolling) until i either stop it by pulling it back alittle (similar to shooving a locomotive to get is to start, the irony:rolleyes:) or by taking it off the tracks and setting it down again.

    I noticed that my GP38's ( the main offender) is dirty, but the GP40-2 i've been using with the same decoder (and same problems except it remembers it's adress) still has shiny brand new wheels. I rescrubbed the track as well, still nothing. any ideas?
  2. Nomad

    Nomad Active Member

    Do you have plenty of buss feeders to your track? I had a similar problem until I put on more feeders. It seemed the engine kept losing the signal.

  3. green_elite_cab

    green_elite_cab Keep It Moving!

    Yep, my layout was originally blockwired, so there is a feeder just about every 2-3 feet. besides, similar locomotives are rolling over the same spots, and are working totally fine.
  4. diesel

    diesel Member

    Hey GEC,

    If the problem is loss of contact, check in where the axels make contact with the pickups. This is most prevelant on Katos and Atlas. It will affect P2Ks and Athearns as well but they can take a lot more fuzz before you loose power.

    If the decoders are actually forgetting who they are (this has happened to us) I don't know what else to do but reprogram. If you have a PC set up with your DCC you can use software called: Decoder Pro. Have you tried this? Very easy to use, setting speed curves is a snap, very easy to assign/adjust funtions and all CVs are displayed in a list that can be changed to whatever you need.

    Not to knock you but all my experiences with digitrax decoders were bad, I use all TCS.
  5. green_elite_cab

    green_elite_cab Keep It Moving!

    Yeah, i've since torn the whole locomotive down, cleaned it, and rebuilt it, and the decoder is still ridiculous. I think future decoders will have to come from another manufacturer.

    I don't have anything to hook the computer to the decoder though, so i can't use that program. I run MRC Prodigy Express on my layout.
  6. 60103

    60103 Pooh Bah

    We had assorted problems with the DCC system on the Utopia Northern. Not decoders losing memory (usually) but slow recoveries after a short -- locos would restart before the controllers did. Berndt Lenz listened and suggested that we might not have a big enough power supply; we were operating off a 2.5 or 3 amp power pack.
    Unfortunately, the layout was torn down before we could try out a bigger transformer.
  7. baldwinjl

    baldwinjl Member

    This paragraph really sounds like a poor connection/bad contact between the train and the controller, either due to dirty track, or wheels, bad contact between the wheels and the decoder, not enough feeders, or maybe even a loose wire at the controller. Or maybe there is something connected to the track that is messing up the signal. I'm thinking something that effectively puts a capacitor across the rails and messes up the edges of the waveform. Power is getting to the loco (it keeps going, even at a good clip), but it isn't responding to commands. It seems to me that there is a timeout for how long it will keep going, it may be programmable. I think I'd double and triple check the connections. I'd also be tempted to try putting the control station output right on the wheels with the loco upside down and see what the behavior is. I really think it is not the decoder.

  8. diesel

    diesel Member

    OK, If you are interested in doing that... All you need is a certain cable. I can find out what that is tonight and let you know. There is a video made by the Sisku-line guy (forget his name). It tells you all about how to hook it up and program as well.

  9. baldwinjl

    baldwinjl Member

    I may be mistaken, but I don't believe the Prodigy Express has a computer interface port. The Siskiyou Line guy is Joe Fugate.

  10. green_elite_cab

    green_elite_cab Keep It Moving!

    yeah, it can't connect to the computer. I don't know what the deal is, but that decoder is alot less finicky, allthough it is hard to tell, since now it definitely DOES need a wheel cleaning. earlier though, it seemed like it didn't matter which locomotive it went into.
  11. diesel

    diesel Member

    I just reread the problem you are having.... I think the problem is either;
    1. DCC isn't hooked up quite correctly or
    2. the decoders themselves, I use TCS decoders exclusively unless I want sound. They are inexpensive.

    I would try swapping out decoders before ripping out any wiring.

  12. TCH

    TCH Member

    I occasionally have had the same problem. it usually happens when the loco has been sitting on the track for a while without being used or selected on a throttle.

    when selected the throttle is turned up and nothing happens. it used to be a real hassle but it has happened enough times that I know what to look for. the first time it happened I just about pulled the loco apart.

    BTW my system is digitrax but the decoders are TCS
  13. TCH

    TCH Member

    happened to me again twice in the last week

    in both cases the train was on my staging track which I had not
    put as many feeders on.
    also noticed that the loco wheels were dirty so am thinking the problem
    is probably electrical.

    last night I rewired this section [more feeders] so will see how this goes. also have cleaned all loco wheels.
  14. Harold Cole

    Harold Cole Member

    I've had the same problems on only a select few decoders,mostly the ones in Atlas.I found a solution (Ferrite Bead Inductors),for some reason these decoders signals get screwed up by inductance.Using the Ferrite bead inductors on the feed wires close from the source output corrected this problem for me.They are fairly cheap at Radio Shack and there is no wiring,they just snap over the wire.The only thing i found out was they do chatter once in a while.

Share This Page