Marklin 3 rail AC Troubleshooting

Discussion in 'FAQs' started by gna, Feb 3, 2007.

  1. gna

    gna New Member

    Does anyone have any tips for troubleshooting Marklin 3-rail AC locos? I bought a used set recently for my nephew, and my brother and I are stumped. I checked the powerpack output, and it ranges from 0-17 vac. I checked the track from outer rail to inner nub, and it's getting power. We applied power directly to the pickup "shoe" and the drivers, and no go. I took off the shell, and this is what I found:


    Could the circuit board be for Marklin Digital? I was surprised to see it under the shell.
    I'm able to turn the motor, and the mechanism turns freely, so I know it isn't jammed or stuck. I'm not sure where to go from here. What should I check on the loco?
  2. 60103

    60103 Pooh Bah

    Gary: have you tried the reverser on it? Used to be you pushed the center button on the power pack for reverse. I can't remember if Marklin has a neutral in their sequence.
  3. gna

    gna New Member

    Thanks for the reply. No neutral on the pack. I did try the reverser, no go. The power pack reverses by turning the speed all the way down and a little past--just like the Marx train from my youth.

    I got this as a tip:

    I tried flipping the dipswitches and it works, so problem solved.

Share This Page