Loconet USB problem

Discussion in 'DCC & Electronics' started by seanm, Jun 8, 2008.

  1. seanm

    seanm Member


    I have a new Loconet USB that I was testing last night very unsuccessfully. Since my layout is not even started yet, I am doing this all on the bench. Setup is REALLY simple.

    Dt400 in A
    Locobuffer in B
    Prog A and B clipped to a piece of Unitrack
    PC is a Toshiba Satellite
    Windows XP
    Locobuffer places USB drivers as COM4 (com 3 in use)
    Com 4 Set to 57600 baud
    Latest version of Java and JMRI

    I tested before I began by programming a known good decoder equipped loco from the DT400. No problems. Reports back GOOD and I can change the address easily.

    I open up decoder pro and set it to com 4 with DCS100... restart decoder pro.

    At this point I cannot ident the decoder at all. I get a time out while talking to the command station.

    The two troubleshooting steps in the Locobuffer manual work as advertised. I get the correct LEDs lit up it does read the locobuffer. I can even see Loconet commands flowing when using JMRI Loconet monitor if I change speeds on the DT400.

    I cannot even program individual CVs with JMRI CV programmer. Time out again.

    Things I have tried (none successfully):
    Removed and reinstalled Locobuffer driver
    Reboot laptop several time
    remove USB plug and replace... (makes appropriate sounds)
    Tried different Loconet cable
    tried different USB cable
    Tried setting flow control to Hardware or Xon Xoff
    tried a few different baud settings
    Tried setting termination in the Locobuffer. (on or off no difference)

    At this point, I think it all points to the Locobuffer itself. For some reason it cannot talk TO the Loconet, though it can read FROM it.

    Any other opinions or things I could try??

  2. woodone

    woodone Member

    Do you have this hooked up to a programing track. That is one thing that must be done. Then make sure that you ae using the program mode to it.
  3. nolatron

    nolatron Member

    If you seeing your DTS 400 commands, then Locobuffer is at least seeing the Loconet.

    Can you do something simple such as turning on/off track power using JMRI? Look under the Tools menu for "Power Control".

    Also, are you picking "Service Mode" in Decoder Pro?

    You might have to simply manually pick the Decoder model in the list too.
  4. seanm

    seanm Member

    Thanks for the suggestions!

    Yes, I am hooked to the track from the ProgA and ProgB on the DCS100 using alagator clips on the track.

    I am using the Service Mode programmer not OPS.

    I cannot turn the power to the track on or off from JMRI at all. No change. I can do that from the throttle no problem at all.

    I think what puzzles me the most is I can see data on Loconet Monitor in JMRI.

    Frustrating. I think I will try and start again from scratch.
  5. seanm

    seanm Member

    Good suggestion. I am not running anything other then Avast anti virus on my PCs. Also just FYI, I am a computer help desk senior, so I am not new to troubleshooting. Not tooting my own, just giving frame of reference.

    I think it is excellent idea to try it with Anti virus off! I will try that.

    Also, have now tried it on both my Laptop and desktop PC with the same results except the chosen com port on the desktop is COM 5. All other results are exactly the same.
  6. seanm

    seanm Member

    Ok. Turned off Avast antoi virus. Same results. Grrr...
  7. logicman

    logicman Greybeard

    The way that windows handles USB and comm ports is a kludge.

    Firstly, in the days of serial ports, ports 1 and 3 and ports 2 and 4 shared the same interrupts.

    USB can emulate serial, but it's a pain.


    If you have a USB (edit did I really write serial?) mouse - replace with a ps/2 one.
    If you have any other USB gadgets - printer, scanner, camera etc. -
    uninstall them.

    Make sure that the USB device giving the problems is installed in isolation.

    If a usb device fails to work after an isolated install (i.e. no other usb devices present) then it is probably faulty.

  8. nolatron

    nolatron Member

    dd What kind of cable are using? A pre-made one or one you cut yourself?

    I recently had an issue with loconet (if anyone remember my garbled screen DT400), and the cause was something with the crimp. I re-did the cable connectors and the issue went away. Something else to check.

    It's really odd that loconet is being seen, but JMRI can't talk back. Usually it's all or nothing. A cable issue might cause this is if the Rail Sync lines aren't both fully connected perhaps.

    What happens if you unplug the DT400 and plug the locobuffer in the A port by itself?
  9. seanm

    seanm Member

    The sugestions here and on the Digitrax Yahho group were terrific! We narrowed it down to the CTS line in on the device. It was coming up as FALSE on any system I tried and that could account for recieve but not send situation I had. Any requests to the loconet were not being cleared to send. I got a nice email from Dick at RR-CirKits and he is likely going to replace it for me shortly. It does sound like a bad device..... Once I get this totally solved I will let everyone know.

    Again, thanks to everyone for the great suggestions. This is anopther reason the interenet is so great!!!
  10. steamhead

    steamhead Active Member

    I was going to suggest you try thr Yahoo group...but I see you've already been there....
  11. seanm

    seanm Member

    I received a replacement unit from Dick and Karen at RR-CirKits and the unit works great! I had a bad unit. They shipped me a new one and I received it on Thursday. They got it to me in 4 days and included a return envelope and postage for the bad unit. Great people to work with. If you ever need any of their products, they will stand behind them!! (I have no connection to RR-CirKits other then purchasing hardware from them)

    Thanks again everyone!
  12. jesso

    jesso Member

    Thanks for letting us know that it works, I have been thinking about purchasing a zephyr and the usb connector and I was getting a little nervous about it reading this thread.

Share This Page