Lights won't switch on on reversal

Discussion in 'DCC & Electronics' started by toodlepip, Jun 15, 2010.

  1. toodlepip

    toodlepip New Member

    Hoping you can help out here. Currently my loco fleet is Frateschi (Brazilian), they come complete with 8 pin for DCC, with a plug when using conventional 12v dc.

    When in this mode the lights work in both forward and reverse. Plug in the DCC plug (TCS MC2) and the headlight (or is it the tailight) lights up, and shows as forward on the controller. Switch to reverse and no light (but the other one goes out).

    What makes me think the lighting is not quite right is that when in forward the light that comes on is via the yellow (rear light) wire and there is no light from the white (headlight) when the control is switched to reverse.

    I tried the TCS site and tried using blue as a common return for both lights but neither then light up.

    Help please!
  2. haberbeckbrandao

    haberbeckbrandao Carlos AHB

    Frateschi DCC connection problems.

    Hi, Toodlepip, good evening!

    My name is Carlos and I live in Sao Paulo, Brazil.
    My HO fleet has only two locomotives from Frateschi (V-8 electric, similar to your US EP-4 - see my avatar), and I don' use DCC, but I think that the Frateschi staff itself
    can help you about your problem.
    The Frateschi homesite is - but I know many friends in our railroad model club in Sao Paulo which are regular DCC users, including
    Frateschi diesels. If I can help you, please, contact me.
    My job's e-mail is:
    Best regards

Share This Page