HPI Nitro Star T-15

Discussion in 'RC Offroad Forum' started by jackal575, Jul 18, 2004.

Thread Status:
Not open for further replies.
  1. jackal575

    jackal575 Member

    is this motor any good? im gonna put it in my Inferno TR-15 (almost double the HP) :D:D
  2. jackal575

    jackal575 Member

  3. redheat

    redheat Member

    What do you have now? why not go with a .18. Double what hp.
  4. jackal575

    jackal575 Member

    ive got the stock GS-15R in my TR-15 now and it has no low end at all. GS-15R has 0.7 hp (i think) and the T-15 has 1.2. i didnt go with an .18 because i was looking at the HPI .18 ss but aparantly(sp) it isn't out in HK yet

    ps: what's the torque like with the T-15?
  5. redheat

    redheat Member

    Wasp .18 should work. Does that .15 have a restrictor in it like the gt does if so pull it out . If you dont have it then I would say that your bottom end is to rich. what are your carb settings and how much fuel have you run threw the notor?
  6. jackal575

    jackal575 Member

    ive run about 2 quarts through it and it doesnt have a LSN

    why are people buying stuff off the OS CV line when this engine is the same cost but hp is 3 fold and has the same mounting dimensions???
  7. redheat

    redheat Member

    No l/s thats interesting.
  8. jackal575

    jackal575 Member

    the compression is shot anyway so im not going to buy a new carb. i also want to get a three pin flywheel and three shoe aluminium clutch shoes from tower cuz the clutch at the moment wont transfer all the power from whatever motor im getting efficiently. why doesnt someone make a manually operated clutch which locks rather than relying on centrifugal force to transfer the power?? it could be attached to the throttle servo. i think it would be alot better than having to replace worn clutch shoes.
  9. jackal575

    jackal575 Member

  10. redheat

    redheat Member

    That cluch doesnt lock , As far as aluminium shoes go I dont like them,tried them on my Maxx at first they worked good nice grab but after about 1/2gal. they started to hang up causing my clutch to stay ingaged went back to the MIP 4in1 they work great.
Thread Status:
Not open for further replies.

Share This Page