How do i get clips back on? lol

Discussion in 'N / Z Scale Model Trains' started by lightbulb8817, Dec 25, 2003.

  1. lightbulb8817

    lightbulb8817 New Member

    Obviously, I am very new to model trains.

    The clips came off my train. I find it extremely hard to get the spring in place then put back on the clip. How do I properly put the clip back on?

    If my explanation is unclear, my problem is shown in the following image.


    Merry Christmas!
  2. lightbulb8817

    lightbulb8817 New Member

    Nevermind... I fixed it. I should have tried before I posted.

    But I do have a relating question: How do I prevent my trains from detaching... In other words, when I have 1 engine and 5+ carts, my carts would detach from the rest of the train, usually the same carts cause the detachment.

    Are there any websites I can visit that'll answer all these dumb questions?

  3. SD90

    SD90 Active Member

    If the couplers are the stock ones that come with alot of cars and locos, that would be your problem. They don't stay connected very well, you should try to switch them to Atlas or Micro Trains, that will fix your problem.

  4. lightbulb8817

    lightbulb8817 New Member

    Where can I find thos couplers? My local shop (Hobby People USA) doesn't have much of a selection.
  5. N Gauger

    N Gauger 1:20.3 Train Addict

  6. lightbulb8817

    lightbulb8817 New Member

    Ahhh, now i feel embarrassed :oops:

    But do you recommend any train site over the others? I don't want to risk buying from a crooked dealer.

    BTW, i need couplers for N scale trains.

  7. lightbulb8817

    lightbulb8817 New Member

  8. rcwatkins

    rcwatkins Member

  9. TiVoPrince

    TiVoPrince New Member

    Also try your local shops, (Can't recall name) on Procyon west of I-15 and Train Exchange just south of Sam's on Boulder highway

Share This Page