HELP!! Novak Super Sport Brushless Problems

Discussion in 'RC Offroad Forum' started by jonatay, Mar 18, 2004.

Thread Status:
Not open for further replies.
  1. jonatay

    jonatay New Member

    I have a DuraTrax Evader ST with a newly installed Novak Super Sport Brushless Motor System and am having many problems. After only 1 1500mAH battery pack the ESC overheated and shut down. I came in to the troubleshooting guide which isn't much and found that I may have too low a gear ratio. I had 23T pinion and 88T spur. So i changed to a 20T pinion. I also read about receiver interference with the ESC so I moved my receiver closer to the front of the car. After several hours to allow the ESC to cool back down. I took it out with another 1500mAH battery pack. This time it was the same thing. It got really hot after about 5 mins. Also, It seems to have maybe some interference problems which I have never seen before. Sometimes It may turn to the right without actually making it turn. The red LED that should stay on in neutral will sometimes flicker. Is there anything that Im doing wrong? Somebody please help!
  2. mastmec

    mastmec Member

    First check for problems on the chassis, gear mesh too tight, bad bearing in a wheel or trans, pull the pinion off and roll everything and make sure it's all free.
    What kind of battery and motor connections do you have?
    Are the batteries getting hot too?
    How about the motor? Hot?
    The flickering is probably just you throttle adj on the TX a click off.
    What motor did you run before the swich, if a stock motor you should run the same pinion and should be able to go up a tooth or two.
  3. jonatay

    jonatay New Member

    The connections are all the stock Tamaiya style connectors. The battery does get hot. The motor stays cool though.
  4. jonatay

    jonatay New Member

    Yeah it was the stock motor which is a modified 20 turn photon speed motor with a 20T pinion gear
  5. ericmcgehee

    ericmcgehee Member

    hey john, i was going to call you today and see how it worked.anyways how do you paste pictures on here? im trying to send someone pics of those t maxx's.he was wanting to buy one.
  6. ericmcgehee

    ericmcgehee Member

    http://www.wildhobbies.com/forum/topic.asp?TOPIC_ID=948 hey jon, i was looking around and found this site. they said their esc's got really hot too, and they used the 20 and 23 tooth gear and would probably go up a few teeth more. but said it didn't get as hot with the 23 tooth.bv
  7. jonatay

    jonatay New Member

    I ran the brushless system with no load on it and it still overheated in about 3 mins. I called Novak and they said that something is definitely wrong, so I'm sending it back.
Thread Status:
Not open for further replies.

Share This Page