help me plz!

Discussion in 'RC Offroad Forum' started by mxking171, Jan 28, 2004.

Thread Status:
Not open for further replies.
  1. mxking171

    mxking171 Member

    hi guys if anyone could help me with this thx anyways ummmmm i was driving my electric stampede the other day in the snow and i came inside and recharged the battery and when I put the battery in i had no steering or throtle so i think my reciever is wet or i wrecked it ummm what should i do ive already tried to let it dry but i cant see any water thx. And next time I will wrap it in somthing. Snow is so fun!
    :D
  2. timrock

    timrock Active Member

    it might be shot.to see if it is the reciever for sure try another one from another car.

    also,when you run it in snow you should put the reciver in a rubber balloon to keep it dry.
  3. Ya, any time I run in the snow, I have my receiver and speed control "ballooned" and than I put a layer of saran wrap over the electronics and tape it to the bottom of the chassis, seems to work fine for me. I beleive timrock has walkthrough on how to balloon your receiever (?)
  4. timrock

    timrock Active Member

    you can walk him through it since i dont balloon any of my recivers for the reason being,i only run my cars on dry road and tracks.he is better off getting addvice from you about that.
  5. mxking171

    mxking171 Member

    ya i screwed myself i actually ran one battery and then came in and charged it and while it was chargin put a bag around the reciever then when the batterie was done i put it in and it didnt go so then i was playing with it and when i take the stering servo out i get throtle no steering and then when i put em both in they dont work any suggestion?
Thread Status:
Not open for further replies.

Share This Page