help duratrax ST pro

Discussion in 'RC Offroad Forum' started by joshua2verizon, Mar 30, 2004.

Thread Status:
Not open for further replies.
  1. joshua2verizon

    joshua2verizon New Member

    this is a bit hard to xplain but here goes... I have an ST pro. it has been about a year since ive used it so finally i decided to break it out. it ran good until now. i opened the throttle and it stopped moving so i let off the throttle but the engine was still "going". i shut it down and restarted it. it was idling and i slowly opened the throttle and it wanted to take off but it wasnt moving. it seems like the throttle gets stuck. i took a look at it and found that the gears were fine( i did the paper-crunch test to make sure it was a tight fit. help would be greatly appreciated. do you think i could have ruined the engine???
  2. atc1100rider

    atc1100rider Member

    Ariane 3 rocket

    when you set it up did you put after run oil in it?
  3. atc1100rider

    atc1100rider Member

    how old is fuel are the bateries in the car good?
  4. joshua2verizon

    joshua2verizon New Member

    no i have never used after-run oil. the batteries in the remote are going low but i still dont see how that is significant with the engine being at full throttle and not moving.
  5. atc1100rider

    atc1100rider Member

    engine is fried man no after run oil means hat stuff builds up in the engine what kinda engine and what kinda car is it it might sstill work if you take it all apart and clean it please tell me what kind it is the egnineand the truck or car which ever
  6. mastmec

    mastmec Member

    The engine runs, revs up, but does not move, is this correct?
  7. joshua2verizon

    joshua2verizon New Member

    yes correct. im gonna mess around with it today and see what i can do
  8. osbornel

    osbornel Member

    dude, ALWAYS use after run oil, its essential to a nitro engine.
  9. mastmec

    mastmec Member

    Check your clutch, make sure it's not stuck. And the flywheel.
  10. joshua2verizon

    joshua2verizon New Member

    this is weird. i fired it up and its not sticking-the throttle. i to open the throttle to full just for it to "barely" move. im not sure what the clutch is. the gears seem to fit fine! what the heck could this be?
  11. So does the engine actually turn, if it does than it might be one of both of your joints. That happened to me yesterday, my Ultima just stopped and I would rev the engine and it would move alittle bit. I found out that one of my joints had loosened up. Also make sure your tires are seated on the little metal rods in the rear so that your tires don't just sit there while the axle spins. Thats probably not it but ya never know...
  12. joshua2verizon

    joshua2verizon New Member

    the gears turn but the drive shaft ( i think its the drive shaft) wont turn..
  13. Alright, so I dont think its an engine problem. Start checking out your drivetrain and driveshafts to see if there are any problems. I think the set screw where your joints is might need to be tightened. I actually put a little CA glue in mine to make sure they don't slip.
  14. joshua2verizon

    joshua2verizon New Member

    wow.. guess what i did strip the gear :( the gear on the outside(bigger gear) is stripped but not the smaller one(inside of larger gear) i can see that the engine was a little crooked. that will be the third gear :(
  15. joshua2verizon

    joshua2verizon New Member

    looks like the truck is going back up to the shelf. gears are stripped, the screws were too tight and i stripped the screws so now i cant move the engine in the right spot and my hobby shop just got rid of their RC repair guy :( thanks for your help though guys
  16. rockn82

    rockn82 Marx Brother

    Cut the heads off of the engine mount screws. Or use a file if need be. Then just grab the stub with a pair of pliers and take the screws out. Don't give up on it so quick. Its a hobby and your the repair guy. LOL. Keep asking questions if you dont know and we will all help ya when we can. Theres a lot of knowledge here (besides timrock) and there should be no unanswered questions. Heck after all the experience I have I still cant figure out when my receiver batteries are dead. LMFAO.
  17. joshua2verizon

    joshua2verizon New Member

    haha thanks for the inspiration :) .... ill try to get those screws off then straighten out the motor. then my next step would probably be to go to my hobby shop and get new screws and the new gear right? oh and apply the lock thread stuff. ok my engine- actually my whole car is filthy with oil, mud and grass. i heard that denatured alcohol is good for the engine and stuff. as with me being a beginner but a smart beginner i was thinking of taking the car apart to clean it. i could probably learn alot from it to. any hints/tips appreciated!
  18. joshua2verizon

    joshua2verizon New Member

    how exactly do i cut the heads off? i dont have a file either
Thread Status:
Not open for further replies.

Share This Page