Has my decoder died?

Discussion in 'DCC & Electronics' started by Woodie, Feb 3, 2006.

  1. Woodie

    Woodie Active Member

    I've got two decoders that this has happened to. NCE D13SR basic 3 function decoders. Both locos worked on DCC last time I used them a few days ago. I did, however, put them on the programming track (to read all their CVs, and load into the pooter) before I put them on the main to use them.

    I can program them, on the programming track. Read and write all the CVs, and also "reset" the decoder to defaults. Both via pooter and cab controller. Can change to loco address, etc etc etc.

    I can apply DC voltage to the wheels and the motor turns over (DC operation CV enabled set). (set DC operation "off" and the motor DON'T turn when DC power applied to the wheels.) Program it back "on" and the motor turns when DC power applied. I can't see how any wiring could have shorted, or be incorrect, as power gets through the decoder, to the motor, when DC voltage is appplied, and the DC enable CV is set "on".

    But the things just do not respond when on the DCC main track. No headlight on/off works. All dead. But I can program it on the main and the CVs change, cause I can read them back on the programming track. All my other DCC locos are fine.

    Have my decoders "died" in some fashion? maybe overheated?
    Any thoughts would be appreciated. Thanks.
  2. Gary Pfeil

    Gary Pfeil Active Member

    Odd. No idea but when I'm faced with something like this I swap decoders with one in a loco which works and see what happens. I use Digitrax 123 series decoders (before that, the 121, before that the 120) which all have the straight 9 pin connector on the decoder, making swapping easy. Although it sounds strange, I have had a similar problem (not sure because I never tried it on dc) where a loco was brain dead. Installed a decoder from another loco, worked fine. Put the decoder from the problem loco in the loco which donated its good decoder, programmed the new address, and it worked! Never figured it out, but was willing to accept the result!
  3. Woodie

    Woodie Active Member

    Just to add to this, Gary, one of these "brain dead" locos, when I was using it the other night would not respond when using a computer throttle (JMRI software), yet it would from the cab controller. No probs with other locos responding from the computer, but this one just wouldn't. Yet it was fine from the cab controller. It would respond to CV programming on the programming track using the computer, but it would not run. It was sorta "half brain dead". I thought it might have something to do with short v/s long address set wrong accidentally, but nup. Twasn't that. Now it don't respond from either.

    The other loco sorta responds on the programming track (as it always did) by giving a little "jerk" every time a CV is changed. It still does that, as it always has. (It's only a railcar, not loco, and quite light, with a decent motor in it).

    hhhmmmmmmmmmmmmmm.................. I'll put another decoder in it, and see how it goes. The decoders I have are not "plugged", just wired straight in (soldered).

    **thinks** I might just resolder the wire joins. Might be a weak join in there somewhere that's corrupting the DCC commands, and not recognising them like it should.
  4. Woodie

    Woodie Active Member

    Worked that one out. Even though you can program the decoder from JMRI with a "long address", there must be a problem in the software when addressing a 2 digit long address frmo the throttles. I had set the long address (and activated "long address") as 72. (road number B72). JMRI will not drive locos via it's throttles with a 2 digit long address. Set the long address (even via JMRI) to a 3 digit number (172) and it responds fine from JMRI. hmmm........

    Had a close look and one of the wires from the pickup was only hanging on by a single strand of wire. It just broke off quite easily when I tugged it. resoldered all the joins, and it is still "Brain dead" from any throttle. I did not try to program a 3 didit adress in to it. Replaced the decoder before determining the JMRI problem with 2 digit long adresses.

    It ran fine with the new decoder from both pooter and cab controller as installed (default short address 3), but refused to respond from a JMRI throttle when I changed to address to a 2 digit address, yet it would respond from the cab controller. It's the only 2 digit long address DCC loco I have, which was the only dif between ones that worked, and ones that didn't. That's how I worked out the 2 digit address problem from JMRI.
  5. CalFlash

    CalFlash Member

    I'd have to go back and verify, but I think you have to "pad" out 2 digit addresses with zeros. I know eventually I will have to face this problem as my road had "spot" class consolidations numbered 1-176 and I will be modeling 1 or 2 of them.
  6. Woodie

    Woodie Active Member

    I tired that, Jerry. I spent hours on it. Set the "long address" using the NCE cab controller to 0072.

    Go to JMRI, which will read ALL the CVs for you and sets up a roster entry, which includes ALL CV values. You then select the "roster" entry when allocating a JMRI throttle. Nup. No go from JMRI, yet OK from cab controller. JMRI would tell me it was a "long address" and display 72 (not 072 or 0072) in the roster details. Manually enter the loco address in JMRI to 0072 072 or 72, and nup. Still won't go from JMRI..

    Set the long address using JMRI to 0072, 072 or just 72, and nup. Won't go from JMRI, yet it will from the cab controller.

    Even though I set the loco address to 172, and it worked from both, I didn't try an address less than 127. (highest SHORT address).

    There is definitely a problem in JMRI when it comes to 2 digit LONG addresses, but how that interrelated with my "Brain dead"decoder (if at all), I'm not sure yet.
  7. Woodie

    Woodie Active Member

    Oh deeeerrrrrrrrr. :curse: hamr hamr hamr wall1 wall1 wall1 :curse: :curse:

    One really should read websites. From the JMRI website:

    I did do that (many times) i.e. check to ensure the roster entry was "long address", but I'm not on that new "test" version that is supposed to support that NCE functionality. I'm on the older version, which, obviously, had that problem.

    And you know what? The "other" decoder (of the two that are "Brain dead") I had also set up with a two digit "long address".

    The plot thickens, as they say. :curse:

    Both decoders that are now "brain dead" were set to two digit long addresses, (via cab controller, and worked fine from cab controller) and then had settings & CVs (including long loco address) values written from JMRI. That's when the problem started.

    I'll try the other "brain dead" decoder (which is still in it's loco) and set it to a 3 digit address tonight when I get home, and see if it returns to this world.
  8. HPRL

    HPRL Member

    Oh my! Do I really want to go with DCC? :confused:
  9. Gary Pfeil

    Gary Pfeil Active Member

    Woodie, why don't you just use the short address format?
  10. Woodie

    Woodie Active Member

    Keep things consistent, Gary. Use long addy on one? Use it on all. :)
  11. Woodie

    Woodie Active Member

    Well that fixed that then didn't it **wipe hands emoticon**

    Wacked the loco on the programming track, got into JMRI, hauled up the default decoder definition, set it to a 3 digit long address, and click the "write all" button.

    Works just a bought one, now it does.

    Set it back to a 2 digit long address, and nup. Don't go from anywhere.

    So these two decoders weren't completely brain dead. It was obviously the 2 digit long address problem of JMRI.

    Setting a NCE decoder to a 2 digit long address from the NCE cab controller works fine, but set it from JMRI, and you have got a brain dead decoder.

    And I took one of them out and replaced it! Not just a plugin, but soldered in...... :rolleyes: :rolleyes:

    Oh well, All part of the great TOOT track experience, I suppose. Don't know whether to sign1 sign1 or :cry: :cry:

Share This Page