Engine damaged?

Discussion in 'RC General & Getting Started' started by vette_7t9, May 16, 2004.

Thread Status:
Not open for further replies.
  1. vette_7t9

    vette_7t9 Member

    ok, so I ran my new OS engine 1 1/2 - 2 tanks on extremely lean side which made fuel boil in my carb. Will that damage my engine and take away some HP? I am very confused and worried.

    Moved to proper forum.
  2. dj6666969

    dj6666969 Active Member

    ok 1 things 1)why did you run it so lean. It would have been better if you posted this in the engine forum Stevem, can you move this thread
  3. vette_7t9

    vette_7t9 Member

    I am told bubbles in the fuel line aint a problem, and hissing noise is cuz of its hot parts. Any tips>?
  4. dj6666969

    dj6666969 Active Member

    you shouldnt have any air in the fuel line. it doesent hurt the engine but the engine needed a steady stream of fuel at all times
  5. jackal575

    jackal575 Member

    needed lol
  6. dj6666969

    dj6666969 Active Member

    NEEDS my bad lol
  7. John Binz

    John Binz New Member

    Did you break it in becuase it didn't sound like you did becuase you said a 1 1/2 to 2 tanks.
  8. redheat

    redheat Member

    Well it sure didnt do your engine any good to run it lean, as far as temp damage ya you more than likely did some, did you even get it broken in before you ran it lean? Good thing it was a OS there forgiving. Run it a little on the rich side for about 2or3 tanks. Take a look at your plug too they hate extreme heat,replace if the coil is all sprung.
Thread Status:
Not open for further replies.

Share This Page