DT400 message "no-d"

Discussion in 'DCC & Electronics' started by Gareth, Oct 13, 2005.

  1. Gareth

    Gareth New Member

    Just tried to program a NCE decoder and didn't seem to work. After the little square I got the message "no-d". It appears to indicate no decoder. Never seen this before. Anyone know if my guess is correct?
  2. tillsbury

    tillsbury Member

    Yup. No decoder, or installed wrong, or you let the smoke out of it somewhere... I take it the programming track is nice and clean and works with other locos?

  3. Gareth

    Gareth New Member

    More problems that "no-d"

    Charles, Thank you for your response. Here's more to the problem;

    1. When programing I get the message "no-d"
    2. Exit programing I select the old locomotive number and it runs just fine.
    3. Try other programing modes it takes the new number i.e. 364, and asks "four digit yes.
    4. Exit programing and nothing on the new number but the locomotive works on the old number.
    5. Then - - after trying to program several times the left throttle will select the new number "364" but nothing.
    6. Then the right throttle select 364 and accept, I get 12 showing on the screen, no Lo.
    7. I have the same problem with Lenz and NCE decoders. I haven't tried a digitrax decoder yet.
    8. Is there any way to determine if the dt400 is going bad or the DCS100?
    9. I've had digitrax systems close to 10 years now and nothing like this has happened before.

  4. tillsbury

    tillsbury Member

    Hi Gareth,

    I'm nothing like an expert, but I suppose I could be another head to bounce ideas off...

    Stuff that comes to mind:

    I'm confused by your statement that selecting loco 364 gives loco 12. That's weird. Is that the number the train used to be?

    First, I'd suggest a factory reset (in Pg mode on the programming track), and then give it a new 2-digit address. Some locos are not as hot on 4-digit addressing, and you'll sometimes have to set the 4-digit flag manually. I find 2-digit easier anyway, as I have fewer than 100 DCC locos ! :-(

    But, the thing that also occurs to me with the 364/12 thing, and also when you say "the throttle will select the new number 364 but nothing" (nothing how? no response from the loco or the throttle?), and this put together with your "I've had digitrax systems close to 10 years now" -- is your DCS100 more than a year or two old? Is it possible that the CMOS battery has died -- this can cause weirdness I've heard. Search on the Digitrax website (or google) about changing the battery inside the DCS100, which is supposed to last no more than 4-5 years, and some recommend you change it every other year...

    Just a thought...

  5. Gareth

    Gareth New Member


    Its usually operator problems. You're not going to believe this. I've been using the PR1 on an older computer to program locomotives, but I upgraded my computer and the PR1 doesn't work in 2000 or xp. I totally forgot about the programing track feature on the DCS100. I wired it up clipped it to a programing track and to my supprise programing worked just fine. No wonder the system could not find a decoder, the correct wires were not connected.

    I still have the weird problem with addressing some locomotives i.e. 4 digit. I can select locomotive 1645 and 108 or 112 appear on the DT400. If I select locomotive 14 it works just fine.

    I tried locomotive 452 and 68 appears. What's weird about this is that I had had loco 268 mu'd to 452, and when I turned the throttle that showed 68 - Loco 268 was running and subsequently the mu link was lost. I selected 268 on the other throttle and it worked just fine.

    I know this all sounds really weird, but your suggestion to replace the CMOS battery is a good one. I'm going to try that.

    Thank you very much.

    I started with a BigBoy (it sat on the shelf for almost 2 years until I built a silencing circuit for the decoder output), then Empire, sold the BigBoy and purchased the DCS100 about 2 years ago.

    My current system is the DCS100, DB150, DT400R, 2-DT100R's, UT1, and UT4R.

  6. tillsbury

    tillsbury Member

    Hee hee. It's known in computer circles as a PEBCAK fault... Problem Exists Between Chair And Keyboard... :)

    For four-digit addressing you do need to check the manuals for each separate decoder, as some of them are a bit trick. It's much easier to stick to 2-digit addresses...

  7. Gareth

    Gareth New Member


    I purchased a CMOS battery and installed it. Checked the old battery and it read 3.117 volts. Not a battery problem, now I have one ready when I get the 7 beeps.

    Well I think I've determined the weird stuff on the DT400. I discovered a weee little sentence in the manual; "wait 30 seconds before turning the power back on"; also, read the recommended procedure to shut down; PWR; (-); sleep; then turn power off.

    Every thing is working great today!

    Not a bad idea to re-read the manual once in a while and above all; patience, patience, patience.

    Thanks for you input and suggestions.

    Will talk again.
  8. MasonJar

    MasonJar It's not rocket surgery

    When all else fails, read the instructions... :D


Share This Page