Decoder issues

Discussion in 'DCC & Electronics' started by jsoflo, Aug 29, 2006.

  1. jsoflo

    jsoflo Member

    Frustration is running high! If anyone can help with a couple of DCC issues I'd appreciate it:
    1) I have a Kato Sd40-2 with DCC, it ran fine, no issues, came back next day, power up and the loco is doing nothing. No lights no power. Cleaned wheels, tried reprogramming, nothing. Contact strips are in contact with wheel contacts as required. Pulled cover off, nothing out of ordinary. Any recommendations?

    2) I have an Intermountain SD40-2T I installed a digitrax board drop in decoder fo rthat particular model. Had to open up the board holding slots a touch to fit the board. All contact strips are in contact with wheels. When its put on track the lights go on but it will not move. It also gives the "DCC warning beep" when placed on the track. Any guesses?

    3) I have an Atlas SD60M with factory decoder, it will start but once going takes no further commands (ie. STOP).

    DCC has been great but these issues come up more often than I'd like so any help that can keep me from these problems in the future is very appreciated.

    I also add this comment: just put a DCC board in one of the new Kato SD40-2 Mid productions and it is magical, insanely fine runner, This is what makes this hobby great!

    thanks in advance.
  2. MasonJar

    MasonJar It's not rocket surgery

    What do you mean by the "DCC warning beep"? The only warning beep that I am familiar with is the "electrical short" sound.

    Can you give more information about what decoders, what DCC system, how the layout is wired (was it originally DC, for example), whether you have tried any programming (and what kind - e.g. on separate programming track, etc).

  3. jsoflo

    jsoflo Member

    O.k. I'll try!

    Yes, that is the sound-- electrical short. Here we go:

    1) The SD40-2 is a Kato early production, I changed the original DC board out for a digitrax direct replacement, DN163K1B. As I indicated, it ran very well, but now suddenly does nothing.

    2) the intermountain SD40-2T. I put in a digitrax DN163IO. here is my fear: the board would not fit into the frame clips. I used a tiny glasses screwdriver to slightly open the frame retainer clips. the board than fit well. I programed it. it read the number back, the light worked but no movement at all. I suspected maybe I over-bent the frame clips, I gently pressed the clips back in, now the electrical short warning.

    3) the 3rd is an Atlas SD60M with stock lenz dcc decoder. It will begin moving forward when speed comes up (before that it will hum a bit and shut off) then it takes off and responds to no other commands.

    The system is an MRC prodigy advance. It was never wired for dc, only DCC. I have many working DCC locos which run no problem on the layout, atlas and Katos. No block wiring, just two bus lines with feeders every 4 feet and on spurs with insulfrog turnouts. Separate program track.

    Did I ruin my tunnel motor?
    what do you make of this?

    any more info. I can give you?

  4. jsoflo

    jsoflo Member

    one more thing: with the Sd40-2 I have tried re-programming and it does not respond, no light blink, no readout of the number I just programmed, etc. I can read the programmed # on the program track for the Atlas Sd60M, and I could before on the IM, untl the plyers incident and short warning now.
  5. MasonJar

    MasonJar It's not rocket surgery

    It appears in the Intermountain, you have created a short in the plug itself.

    For the Kato - try resetting the decoder on your programming track. If that does not work, I am not sure - you may have fried it? Was it sitting on the track when the Intermountain started shorting?

    Can you take out the decoders in question and try them in other locos? That will at least determine if they are functional, and if they work, you have isolated the problem in the loco somewhere.

    What does Lenz/Digitrax say about troubleshooting those decoders? Have you followed the mauals' suggestion(s)?

    What is the "pliers incident"? (This reminds me of the Calvin & Hobbes "noodle incident" ... ;) :D ).


Share This Page