DCC up and running!

Discussion in 'DCC & Electronics' started by oldtanker, Nov 21, 2006.

  1. oldtanker

    oldtanker Member

    I just finished installing a Digitrax decoder in the first engine to get one! An Atrean F7! Next will be a LL P2K GP7 right after the first of Dec.

    I'm using a Bachmann EZ command controller.

    Installation was a snap after downloading the instruction manual from Digitrax!

    Anyone who has been thinking about this and putting it off this is easy! Just follow the instructions that comes with the controller and the instructions for the decoder.

    Good Luck!

  2. EngineerKyle

    EngineerKyle Member

    Congrats Rick.... good feeling to take the plunge and see how wonderful DCC is!
  3. railman537

    railman537 New Member

    Nice job Rick. I will be attempting to convert a few of my old loco's after the holidays. Your post gives me hope!
  4. oldtanker

    oldtanker Member

    Kyle, thanks!

    railman, it was easy!

  5. cwclark

    cwclark New Member

    I still don't know how "wonderful" DCC is....I just connected a digitrax super chief system to my layout last night, did the quarter trick, installed a decoder in a loco and first tried to run it on 03 default..nothing happened....then I tried to put in an address to the loco...nothing happened...then I took another loco that didn't have a decoder and tried to run it on 00..the lights came on and it hummed but still...nothing happened...i'm really frustrated now and about to throw this thing into the gulf of mexico..at least my DC system worked like a charm....
    :curse: chuck
  6. Chris Beard

    Chris Beard Member

    It could be that the engine was not isolated from theframe.

    Once an address is programed you have to get out of program mode and select the engine.

    I don't have bachmann so I am not much hope.
  7. oldtanker

    oldtanker Member

    Check to make sure the decoder instlation is correct and that you are in "run" mode.

  8. cwclark

    cwclark New Member

    The system is a digitrax super chief 8A radio system. There is no run mode. I have to exit "programming" then go into "function mode" and select the locomotive after removing it from the program track and placing it back on the layout. (Read the manual at least 5 times and made a cheat sheet on everything so I wouldn't be in the dark when i did fire this thing up.) The locomotive is an Athearn RTR SD45T-2 so the motor is already insulated from the frame and the decoder just plugs into a harness. I've also removed the keep alives for the signaling system, took all my lighted equipment off the layout because of the capacitors involved that don't like DCC, and removed all of the locomotives from the layout that don't have decoders in them.
    My guess is that i got a bum throttle because the "power on" indicator won't quit blinking and some of the numbers on the display LCD won't light up completely (the number "0" looks like a backwards letter C.)
    Im going home after work tonight and try it on a single piece of flex track. If it doesn't work, then something is either wrong with the command station or the throttle which I'll have to send back to the manufacterer for that 6 week long wait to get it repaired and back to the layout . The maddening part is that I just spent about $1600 for the system, power shields, reversers, and all the decoders for my 30 + locomotives and i still have nothing....chuck
  9. MasonJar

    MasonJar It's not rocket surgery


    If you just got it, try a return/swap at the store where you bought it.

    While the blinking LED and bad LCD display do not sound good, I wonder if you might have your feeds to your program track and mainlines backwards. This might account for not being able to run anything on the main, and your programming difficulty. Ops mode only programs on the main, and page mode only programs on the programming track, for example. So if you tried to use Page to program an address while the loco was sitting what you thought was the programming track, it may have been wired as the main and therefore would not have worked. Same goes when you moved the loco to what you thought was the main - it is actually the programming track and therefore cannot run anything.

    If you have checked this possibility, please disregard... ;)

  10. oldtanker

    oldtanker Member

    Ops, run mode is what I call it, sorry. On my Bachmann setup I push the button for function to run sound, lights and so on. Then there is programing mode. Once you have gotten out of function and programing I call it run mode for lack of a better term.

  11. MasonJar

    MasonJar It's not rocket surgery

    With Digitrax, "OPS" is a programming mode that works on the main...

  12. cwclark

    cwclark New Member

    I can't believe my eyes but it started working last night when i got home from work and gave it another try. I think the problem was the throttle and the way it is supposed to power up and what really happens.
    The book says to push the power button and then the Y+ button. In reality, i had to push the power button and then push the Y+ button TWICE for the power to come on to the track.
    So this is DCC huh?...it's pretty cool! I like the ability to turn the headlights on and off with the F0 function and the way the headlights stay lit when the locomotive is idling. I got my two MP15DC yard switcher locomotives consisted last night and had some fun. Now I'm going to have to install the throttle radio devise. Stooped over with the really short throttle cable plugged into loconet is gonna throw my back out if i keep this up....chuck
  13. oldtanker

    oldtanker Member

    Great Chuck, glad it works!

  14. Chris Beard

    Chris Beard Member

    I'm glad you have your DCC throttle up and runing. Have fun.

Share This Page