DCC Decoder installation!

Discussion in 'FAQs' started by Freelancer, Oct 2, 2003.

  1. Freelancer

    Freelancer Member

    I need help! I have a Digitrax DH142AT decoder that I am trying to install into an Athearn AC4400. I followed the instructions that came with the decoder, but I can't seem to get it to work. When power was applied the light flashed, the instructions said that if that happens then there is a short, so I checked for a short but came up with nothing. So I tried it again, but the light still flashed, when I disconnect the black wire then the light doesn't flash but when I hook the black wire to the light bracket the whole system shorts out and makes a funny noise. The motor is isolated and I am pretty sure that the wires are in the right place. I made no progress so I took it to the dealer that I got it from and he couldn't figure it out either. He lent me another older decoder to see if I could get that to work with it, but it has the same problem. I did however get it so that I could start programing it but it still wouldn't operate. I also tried to install it in an Athearn GP but it had the same problem.
    I contacted digitrax and they were less help to me than the dealer. I am completely lost and hopeless, I hope that someone can help me!

    Thanks, Freelancer
  2. Gary Pfeil

    Gary Pfeil Active Member

    I don't know what the problem is but I'd start by checking the loco (with its motor isolated from the frame, as you've indicated) for smooth operation on DC. Just connect the motor leads to power with clips, do not use the frame. Then test the decoder by connecting the red and black wires to command station track output and the orange/gray wires to a motor. You should be able to run the motor. If this all works, install the decoder but do not connect the lights. If the loco runs, the problem is the light bracket is connected to the frame, which is connected to one of the rails. Connecting the light output of the decoder creates the short. You must isolate the bulb from the frame also.

    Good luck.
  3. Freelancer

    Freelancer Member

    Gary, thanks for your help, unfortunately this didn't solve my problem. I tested the engine on DC and it ran fine, so I hooked the red and black wires to the command station and the orange and grey to the (isolated) engine. When I connected either the red or the black to power, then the system would short. Digitrax Tech support suggested that I get a DH123 Decoder and test that, when I connect it, it doesn't do anything at all. It doesn't short out or anything. I installed the DH123 into another engine and it works fine, I also tried the DH142 in the same engine and it also worked, however I couldn't control the lights with the DH142. I know this is a long shot because I can't see any room for problems, but do you think that the harness might have anything to do with it? A short between any of the wires where they all connect to the decoder maybe?

    Once again I greatly appreciate your help.
    Thanks, Freelancer
  4. Gary Pfeil

    Gary Pfeil Active Member

    Interesting that the decoder runs a different loco. Kind of eliminates the decoder itself. The fact that the lighting function didn't work may indicate that the function output was damaged when connected to the light in your AC4400. I haven't been inside an Athearn for awhile. Never in that model. The light bracket usually is live electrically, and the bulb just requires one additional wire. often a brass strip as I recall. So when you connect your lamp output wires to the lamp, either yellow and blue or white and blue, you allow full track power to enter the decoder via the lamp output, which can destroy it.

    None of this explains why your loco runs on DC but will not run on DCC with either of the decoders. Are you absolutely sure the motor is isolated from the frame? Try removing the motor from the model and running it with a decoder on the workbench. Use a pair of alligator clips to connect the black/red wires to a section of powered track. Use another pair of clips to connect grey/orange to the motor directly. If the motor works this way, then either the harness has a problem as you suggested, or the motor is not truly isolated. If you are comfortable with your soldering skills, by all means just hardwire the loco. This is always your best bet. Remove the brass clips which hold the motor brushes in before trying to solder to them! Do so slowly so as not to have the brushes and springs go flying. Put some electrical tape between the motor and fuel tank when you reinstall.

    Model Railroading is fun.
  5. Freelancer

    Freelancer Member

    Gary, the motor was definitly isolated when I checked it, I did like you said and took it completely out of the frame, that is where I did most of the testing. I am pretty comfortable soldering, that is how I installed the 123 decoder, but I fail to see why soldering this will solve the shorting problem. Maybe I will just buy a new 142 decoder, I am not sure where to go now. However if it is because of this style of engine structure then I am sol, half of my motive power is this style.

    Thanks for your help, Freelancer

    Model Railroading is fun, but installing decoders isn't!
  6. Gary Pfeil

    Gary Pfeil Active Member

    Freelancer, I only suggested soldering as a replacement for the harness, which perhaps is/was the problem. IMHO, I would always hardwire as opposed to spending an extra couple bucks for the Athearn harness. Anyway, are you saying that with the motor out of the loco the decoder still won't run it, but it still runs on DC? Question, does the loco, without decoder, run on track power supplied with a command station? That is, when you stated it ran analog, was it with a standard DC power pack or with DCC? I have one loco, one of the first Atlas brought in around 1980, which is the only one I've experienced which would not run on DCC. Ir runs fine on DC, but shorts on DCC. Never looked into it, it's in a box for possible decoder installation someday. I have always assumed it would run when I installed a decoder. Now I wonder. I have never heard of such a thing. If the motor runs on DC but won't with DCC and there is no other factor involved, then the motor must have some electrical problem I am not knowledgable enough to determine. Perhaps you should post this to the Digitrax users group at Yahoo. Since you have other locos of this type, I'd be inclined to pull one of the motors, test it with DC on the bench, then test it using DCC without a decoder, then with the decoder. If it works all three ways, install it in the original loco, properly isolated and see what happens. You may just have a bad motor. Sure is freaky. Let me know how it goes.
  7. Wat Rauscher

    Wat Rauscher New Member

    Try checking the current draw of the motor on DC. If it exceeds the decoder spec then the decode will take that as a short.
    good luck and keep us informed
  8. Freelancer

    Freelancer Member

    Gary, the only reason I got a harness was because this was my first decoder and I was hoping that it would help me to figure out what exactly needed to be done, and then I could do the rest of my decoders without a harness. The engine runs fine on both standard DC and on the DCC command station.

    Wat, Thanks for that suggestion I will check the current draw and see what the rating is.

    I also just recieved a message from Digitrax tech support, all they say now is that I should send it in for repair, and with the progress I am making now I think that I will do just that, I will toy around a little more and if you guys come up with any new ideas let me know. I will also get a hold of the yahoo group.

    I will let you guys know what the out come is, thank you guys so much for your help.

  9. railwaybob

    railwaybob Member

    If the loco won't respond, it's probably because the motor isn't insulated from the frame. Did you place a strip of electrical tape on the loco frame underneath the motor?

    I had a similar problem a couple of weeks ago with an Athearn AC4400 using the Digitrax DHAT wiring harness and a DH163 decoder. The first question our club expert asked was "Did I put a piece of electrical tape on the bottom". My response was "No". He then yanked out the motor, cut a piece of electrical tape about as wide as the space between the two plastic motor mounts to fit over the slot milled in the frame (this is where the bottom copper strip would contact the frame). He then reinstalled the motor, programmed the loco number, turned on the juice, and away it went.

    The instructions don't mention the electrical tape on the bottom.

    For the light, remove the light and copper light socket from the metal post. You'll have to install a 12 volt light to the correct wiring harness wires. Also, install a couple of 27 ohm resistors (see my website for instructions).

    I would suggest that you solder everything, rather than use the clips that come with the DHAT wiring harness. Once you've installed one decoder, you'll find that you can do it without the DHAT kit.

    You might find that the pickup from the front steel post isn't the best. You might have to solder this pickup wire directly to the trucks.
  10. Freelancer

    Freelancer Member

    I'd like to thank all of you who helped me with my dilema. I went to a train show this weekend and after a couple of hours of head scratching someone was able to figure out the problem. The harness' on both of the decoders were messed up. The wires in the connector were switched, the color order of the wires were, green, orange, red, blue, and so on, the wires were supposed to go green, red, orange, blue etc... the orange and red wires were backwards. So they were connected correctly to the engine but the actual connector was wrong. We switched the connections on the motor so that it corrected the mistake on the decoder and it works fine, unfortunately we burned two decoders in the process but I am hoping that Digitrax will replace those because of their mistake.

    Thanks again,

  11. Wat Rauscher

    Wat Rauscher New Member

    oh no------ One more thing to check before installing. I can see how that was very easy to overlook. Do hope digitrax hepls you out.

  12. Tileguy

    Tileguy Member

    Wouldnt a decoder tester have shown this problem??
    Everything ive read so far about DCC(and i am just getting into it mind you) Indictes the need to pretest every decoder before installation with a decoder tester.What exactly will this tester tell you, especially in this type situation.I dont do stress very well:D
  13. Freelancer

    Freelancer Member

    Your right, a decoder test did find that there was a problem. It didn't bring me any closer to figuring out there was a problem with the harness though. I tested the decoder and the tester partially worked (or so I thought), I then tested another decoder, but since the harness was ruined it gave me the same test results, since I knew that the second decoder worked fine I figured that the testers' LED must have been burnt out or something and I just disregarded what the tester was saying. Now that I know the problem I used the tester on a different decoder with a different harness and the tester works fine. Did I answer what you were asking?
  14. Railcon71

    Railcon71 New Member

    Athearn decoder installation

    Gary you need to check to see if the bottom motor clip is touching the frame and also get rid of the head light bracket and replace with a whole wheat bulb. Also you might what to consider replacing the old motor mounts. The new ones will be a little bit higher.

Share This Page