Any digitrax guys here?

Discussion in 'HO Scale Model Trains' started by prodigy2k7, Mar 26, 2007.

  1. prodigy2k7

    prodigy2k7 Member

    I didnt want to go to dcc forum they take too long to respond:oops:

    I got my zephyr today.

    I tried doing a readback of the trains address (factory set to 3) just to see if the decoder could be detected cuz it wouldnt run earlier.

    It got a "D nd" error, meaning the decoder couldnt be detected or has an 'open circuit' what does that mean?

    How do I fix this
    Note: There is power to the rail where the train is at because i can make a short circuit if I wanted to..(i did for testing)
  2. UP SD40-2

    UP SD40-2 Senior Member

    prodigy2k7:wave:, when it comes to some questions, like digitrax tech questions, you are right, sometimes it takes awhile for a response. though i do use DCC, i DO NOT use any of the Digitrax systems, hence it may take a while for the answer to come up, as just like you are doing here, i rely on those that DO USE the digitrax systems to answer the questions;).

    i feel for ya, as i know how frustrating it can be to run into a problem, and have no one right there to help out;). i hope you get a quick response here:thumb:. :)-Deano
  3. prodigy2k7

    prodigy2k7 Member

    thanks a lot :)
  4. Gary S.

    Gary S. Senior Member

    I have a super-empire builder, so can't help with the Zephyr and reading the CVs. Is it doing the same thing on all the decoder-equipped locos you have? Or just that one loco?
  5. trainnut65

    trainnut65 Member

    Ok here is the trouble I think. Are you programing on the mainline this will make the D nd come up. and if so you have to program on a diff set up with the zephyr. Look on the back of the unit, There is a prog A and a prog B hook up. put the wires from the track in there to do the programing. then when you are done put the wires back in Rail A and Rail B to run the loco's. I Did the same thing when i first got mine. Let me know if this works and if you need to know anything just ask.
  6. prodigy2k7

    prodigy2k7 Member

    Yes I tried to do that but I cant even run the train with factory settings..

    Note: It runs in DC mode on my old DC powerpack..
  7. IAIS 604

    IAIS 604 Member

    What is the loco ???

    If it is an Atlas, verify the plug is is the DCC position instead of the DC position!

    If not an Atlas (or an Atlas with the plug in the correct position), try using a program track.
  8. prodigy2k7

    prodigy2k7 Member

    Yes, I created another piece of track to hook up to the prog terminals on the back..

    And Yes, I moved the jumpers to digital mode (if i remember correctly, toward the front)
    Note: I ran it in DC mode for a few days. Could this screw it up somehow?
    What is the chance of it not being dcc ready (i mean like something is wrong with the chip itself...defective)
  9. steamhead

    steamhead Active Member

    I have the feeling this loco may NOT be decoder equipped..Is this a brand new engine..?? Did the add/shop or box say DCC READY or DCC EQUIPPED or DCC ON BOARD..?? If it said DCC Ready, it needs a decoder...
  10. Nazgul

    Nazgul Active Member

    My first thought was the same as Gus'.
    Do you know someone else with a dcc engine that you could try running on your layout?
  11. prodigy2k7

    prodigy2k7 Member

    Thanks guys for the help!
    Hey nazgul, thanks for coming.

    trainnut65 got me on yahoo messenger and helped me.
    I got it working. Thanks!!!
  12. Nazgul

    Nazgul Active Member

    Good job trainnut65!!!
    I'm just glad you have it working....enjoy!!!!
  13. prodigy2k7

    prodigy2k7 Member

    Thanksssssss :)
  14. MasonJar

    MasonJar It's not rocket surgery

    So, tell us the solution...! :D

  15. prodigy2k7

    prodigy2k7 Member

    Well somehow When I was trying to program it, it returned the error D nd and still actually programmed the address into the loco.

    I changed it to 44 without know I actually succeeded...
    I wasnt able to read back the current address either receiving a D nd error.
    Some reason it finally worked and gave me tha loco address...

    Thats why it wouldnt move I was using the wrong address.

    make sense?
  16. b28_82

    b28_82 Member

    I've noticed programming troubles when the track or wheels are not pristinely cleaned. I would recommend running a bright boy along the track and see if that helps your programming options. If that doesn't work then try cleaning the loco's wheels.

    I've never gotten that while programming with my Zephyr but definately that came up on the super chief at a club member's house layout.
  17. prodigy2k7

    prodigy2k7 Member

    The track is brand new :p
    Note: Read replies, its fixed :p

    Thanks anyway

Share This Page