Any Broadway Limited Gurus out there?

Discussion in 'DCC & Electronics' started by vanda32547, Nov 20, 2004.

  1. vanda32547

    vanda32547 Member

    I just received my Broadway Limited NYC J1e, that I bought on November 4th, and am having a major problem right out of the box.

    All the sound effects work great but the blasted engine WILL NOT run :mad:
    I went through the whole recommended factory default jumper remedy in the Operator's manual and that did not work either. Instead of hearing the recommended 3 whistle hoots I heard a voice say "RESET". This procedure did nothing to correct the problem. :(

    It was suggested that I try running it with standard DC power instead of DCC to see if it would run that way.... IT DID NOT :confused:

    Any suggestions? Other than sending it back to Broadway Limited for service (ON A BRAND NEW OUT OF THE BOX ENGINE) I have already written them for suggestions.

    Frustrated & Disappointed,
  2. kchronister

    kchronister Member

    Bob -

    Regrettably I can do you no good, but since a BLI K4 is top of my Christmas list, I'm keen to hear how this resolves for you. Keep us posted.

  3. theBear

    theBear Member

  4. vanda32547

    vanda32547 Member it is an intermittant problem....

    I am really confused :confused:

    My problem seems to be an intermittant one. Sometimes when I power up my DCC system, the loco will run and then other times it just makes the sounds but will not run. I am starting to think it has something to do with my DCC system and the way it is programmed. I am using the MRC Prodigy Advance System.

    Any insite?

  5. theBear

    theBear Member


    I haven't a clue right off the top of my head.

    I'd check the following:

    1. that the controller was set to the same address that the loco was

    2. that the track is clean

    3. that the loco wheels are clean

    4. that there weren't any pieces of packing material in the electrical pickup area

    5. that the controller was set in operating mode, not service or programming

    6. that the controller and loco are using the same speed settings

    7. that there was a good solid connection to the track

    8. that the loco was right over that connection

    Hope that gives you something to go on.
  6. toopoor

    toopoor New Member

    Not sure if your BLI has a shutdown feature like my T1 from BLI. There are key sequences, (F6 I beleive) that when pressed twice place the loco in a idle mode pressing it again, makes it go to shutdown. Press it again and it comes out of shutdown and into startup, then the engine will run.

    You can check the manual and it should tell you about any shutdown feature the loco may have.

    Hope that helps

  7. spitfire

    spitfire Active Member

    I had a similar problem with my (first release) J1e Hudson. It was working fine, then I tried to change some CVs, and suddenly it wouldn't work - not even the lights came on. I also tried to reset to factory defaults with no success. I took it in to my LHS and the DCC guru there couldn't find the problem, so it was sent back to BLI. They couldn't find the problem either, and ended up replacing the board.

    The resident DCC guy at my LHS told me that you can't program a BLI on the programming track with the Digitrax Zephyr, which is what I have, as it doesn't put out enough power for those engines. He also said BLI is not NMRA compliant. He also said that there are a lot of faulty boards out there - and not just BLI.

    If you do end up sending the unit back to BLI, I wish you luck. I had a horrible experience with their "customer service" when the unit was lost by the USPS. They thought I should wait while the post office had a look for the parcel. After 3 months of waiting I told them I wanted a replacement. There was a lot of dithering on their part and finally my LHS had their distributor call the owner of the company to ok a replacement. All told I waited 6 months from the time I first sent them my engine. Let's hope they've learned something from this and have put a policy in place.

  8. wjstix

    wjstix Member

    The Hudson being their first loco does seem to have some problems with programming that later models don't. (My USRA mike was quite easy to program compared to my hudson.)

    Could be that shutdown feature that toopoor mentioned, could check the BLI website for their DCC manual. BTW there are some functions and such that are different on the hudson than on other BLI engines !!

    Could be the system you're using, in the "comments" section about using the various systems to run BLI engines it does say that there have been problems programming BLI engines with MRC systems. (pg.119 of the DCC manual v.2)
  9. vanda32547

    vanda32547 Member

    Thanks ya'll for all the great input. My engine is now working fine and I did not have to send it back to BLI! It appears to have been a problem with my DCC system and not the engine. All is right with the RR world now.

  10. CalFlash

    CalFlash Member

    I've bought what will probably be my only BLI locomotive. They seem to aim to the RTR and unknowing crowd. I bought an E-7 which has single chime horns on it and the only horn sound is a multi-chime. I wrote them and they gave me all sorts of double talk - they just don't get it. The bell is horrible too. I'll wait for Soundtraxx to get out their Tsunami and use it for all future sound units.

Share This Page