ANOTHER Pepakura question!

Discussion in 'Gallery & Designs' started by ltla9000311, May 10, 2009.

  1. ltla9000311

    ltla9000311 Member

    Hey all, when I import a model into Pep I have edges that are marked in red. Now these are isolated edges that Pep doesn't recognize as being connected. But no matter what I do, short of redrawing the entire model in Sketchup, they won't go away. Can anyone point me in a direction that might alleviate this problem? Is there a way to "connect" them in Pep? Is there something being lost when exporting from Pep? Or do I just give up because there's something else I don't understand that can't be fixed? I don't like to say this but I feel dumb here.:confused:

    Here's a pic of what I'm talking about.

    Attached Files:

  2. Edges

    I have found that sometimes the red edges are due to extra panels in the model or as you say some edges are not joined up. Sometimes models have unique vertices for each panel even though they are in the exact same position as others. I would be interested in knowing what pep could do about this. Also being lazy, can you change or adjust a panel colour or texture in a .pdo model?
  3. shiftdel

    shiftdel Member

    You can try to correct some of the unjoined vertices using the Pepakura menu option: 3DModelWindow\Join Adjacent Isolated Edges. It will work for some of them, but probably not all, because Pepakura will always shows a red line for edges which are not joined with anything.

    It is not always a problem, as some parts of the model may be not joined. Suppose a 3d model of a box. If the box has all 4 faces, Pepa will shows it OK, but if it don't have one of the faces, the edges of the faces which would connect with that missing face will be shown red.

    If you expect to glue those red edges onto another part of your model, you just need to create flaps on those edges (Pepa don't create them automatically, in this case).
  4. MrCutter

    MrCutter New Member

    Hi folks !

    Today i strumbled about the same problem. I have designed a building in Sketchup, exported it to Google Earth format. After importing the model in Pepakura it showed many red lines, which i could not remove.

    To examine this problem, i reduced my model to one single shape, the base plate. Again here the one line apperes in the base. (see pictures)

    It seems that Sketchup is not generating clean 3D meshes. Now my question : Is there a possibility to clean my model in an other application than Sketchup, to get rid of the red lines ... or ... is there a possibility to avoid such things in Sketchup ???

    Many thanks for a reply in advance !

    Attached Files:

    • su.jpg
      File size:
      38.3 KB
    • pep.jpg
      File size:
      35.7 KB
  5. voltron5

    voltron5 Member

    In sketchup you need to create two lines connecting the unjoined part to the rest of the model. See pic attached, let me know if this resolves your problem.

  6. MrCutter

    MrCutter New Member

    This works ! Fantastic !

    Thank you very much !

    But for understanding and explanation, what are the reason for this problem ???
  7. voltron5

    voltron5 Member

    I honestly don't know why Pepakura does that, I just know how to fix it as Sketchup is the modeling program I use as well.
  8. MrCutter

    MrCutter New Member

    The main thing it now works !

    I have searched nearly one hour through the web for an answer, but now i can finish my model and make a testbuild.

    Thanks a lot !

  9. voltron5

    voltron5 Member

    No problem at all. One other thing I thought of that could create red lines is reversed faces. In Sketchup, under VIEW scroll down to FACE STYLE, then select MONOCHROME. This will change the view setting so you can see the direction the faces are 'facing'? A white face means it's facing the correct direction(out) A grey face means it's reversed(in) To fix a reversed face just right click on it and select reverse face.

    Also sometimes Sketchup will create a face inside the model, usually you can see them indicated by a line with white dashes in it. For this just hide one of the outer faces so you can see into the model and delete any faces you may find.

    If you need any more help just post here, I would be gald to help you as much as I can.

Share This Page