3 Rail Power Problems

Discussion in 'FAQs' started by Crazybikerchris, Jan 19, 2005.

  1. Crazybikerchris

    Crazybikerchris New Member

    Hey Fellow Railroaders,
    I`m having some trouble that must be simple but not simple enough for me! I bought a MTH locomotive, RealTrax track and a Z-750 transformer for my son for Christmas. Everything worked fine for a while and one day nothing! All we get is a little grunt from the speaker and the engine does not move. It looked like the connections were ok so we tried one of my new engines. Same thing happened! It worked great for several hours and the next time he went to start it around the track it would not move. Could there be a problem in the transformer causing this to happen? It`s a brand new unit so I thought everything would work fine but no! Do any of you have an idea what the problem could be?
    Thanks For Your Help,
  2. wjstix

    wjstix Member

    To start I would just do a process of elimination. If you have an engine that you know runs fine, try it. If it doesn't work, disconnect the new tranformer and connect up an old one, using the same wires etc. If that doesn't work, could be there's a short in the track or wiring or something like that. If the loco's run with the old transformer on the track, then I guess something is wrong with the new transformer.
  3. Crazybikerchris

    Crazybikerchris New Member

    Thanks for the reply Stix. I don`t have a spare transformer so I`ll need to find someone here who has one. We don`t have any good hobby shops here to go test trains.

Share This Page